zoukankan      html  css  js  c++  java
  • 1129. Recommendation System (25)

    Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

    Output Specification:

    For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

    query: rec[1] rec[2] ... rec[K]

    where query is the item that the user is accessing, and rec[i] (i = 1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

    Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

    Sample Input:
    12 3
    3 5 7 5 5 3 2 1 8 3 8 12
    
    Sample Output:
    5: 3
    7: 3 5
    5: 3 5 7
    5: 5 3 7
    3: 5 3 7
    2: 5 3 7
    1: 5 3 2
    8: 5 3 1
    3: 5 3 1
    8: 3 5 1
    12: 3 5 8
    
    优先队列。
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <queue>
    using namespace std;
    int n,k,d,c;
    int rec[10];
    int times[50005];///记录出现次数
    struct item
    {
        int x,c;
        item (int x,int c)
        {
            this -> x = x;
            this -> c = c;
        }
        friend bool operator < (item a,item b)
        {
            if(a.c == b.c)return a.x > b.x;
            return a.c < b.c;
        }
    };
    int main()
    {
        cin>>n>>k;
        priority_queue<item> q;
        for(int i = 0;i < n;i ++)
        {
            cin>>d;
            times[d] ++;
            c = 0;
            while(!q.empty() && c < k)
            {
                rec[c ++] = q.top().x;
                q.pop();
            }
            while(!q.empty())q.pop();
            if(c)
            {
                cout<<d<<':';
                for(int i = 0;i < c;i ++)
                {
                    cout<<' '<<rec[i];
                    if(rec[i] != d)q.push(item(rec[i],times[rec[i]]));
                }
                cout<<endl;
            }
            q.push(item(d,times[d]));
        }
    }
  • 相关阅读:
    hdu_2224_The shortest path(dp)
    hdu_4824_Disk Schedule(dp)
    hdu_5680_zxa and set(想法题)
    hdu_5683_zxa and xor(非正解的暴力)
    hdu_1429_胜利大逃亡(续)(BFS状压)
    hdu_1254_推箱子(双BFS)
    hdu_1969_pie(二分)
    hdu_2446_Shell Pyramid(数学,二分)
    hdu_2141_Can you find it?(二分)
    5.2 nc + JMX查看分布式程序数据
  • 原文地址:https://www.cnblogs.com/8023spz/p/8511499.html
Copyright © 2011-2022 走看看