zoukankan      html  css  js  c++  java
  • 1142. Maximal Clique (25)

    A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

    Now it is your job to judge if a given subset of vertices can form a maximal clique.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers Nv (<= 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

    After the graph, there is another positive integer M (<= 100). Then M lines of query follow, each first gives a positive number K (<= Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

    Output Specification:

    For each of the M queries, print in a line "Yes" if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print "Not Maximal"; or if it is not a clique at all, print "Not a Clique".

    Sample Input:
    8 10
    5 6
    7 8
    6 4
    3 6
    4 5
    2 3
    8 2
    2 7
    5 3
    3 4
    6
    4 5 4 3 6
    3 2 8 7
    2 2 3
    1 1
    3 4 3 6
    3 3 2 1
    
    Sample Output:
    Yes
    Yes
    Yes
    Yes
    Not Maximal
    Not a Clique
    

    代码:
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <map>
    #define Max 100005
    using namespace std;
    int nv,ne,m,k;
    char re[3][20] = {"Not a Clique","Not Maximal","Yes"};
    int mp[201][201],vi[201],u[40001],v[40001],fir[40001],nex[40001],vis[201];
    int check()
    {
        for(int i = 0;i < k;i ++)///判断集合内任意两点是否连通
        {
            for(int j = i + 1;j < k;j ++)
            {
                if(!mp[vi[i]][vi[j]])return 0;
            }
        }
    ///满足clique
    for(int i = 1;i <= nv;i ++)///判断集合外是否存在一点与集合内点都连通 { if(!vis[i]) { int kk = fir[i],c = 0; while(kk != -1) { if(vis[v[kk]])c ++; if(c >= k)return 1; kk = nex[kk]; } } }
    ///满足maximal
    return 2; } int main() { scanf("%d%d",&nv,&ne); memset(fir,-1,sizeof(fir)); for(int i = 0;i < ne;i ++) { scanf("%d%d",&u[i],&v[i]); if(u[i] == v[i])i --,ne --; } for(int i = 0;i < ne;i ++) { mp[u[i]][v[i]] = mp[v[i]][u[i]] = 1; u[i + ne] = v[i]; v[i + ne] = u[i]; nex[i] = fir[u[i]]; fir[u[i]] = i; nex[i + ne] = fir[u[i + ne]]; fir[u[i + ne]] = i + ne; } scanf("%d",&m); while(m --) { scanf("%d",&k); memset(vis,0,sizeof(vis)); for(int i = 0;i < k;i ++) { scanf("%d",&vi[i]); vis[vi[i]] = 1; } puts(re[check()]); } }
  • 相关阅读:
    Jquery尺寸
    Jquery 位置
    c#编码规范
    手机即时通信文章列表
    缺陷跟踪系统BugTracker。 以下对使用
    用正则表达式来匹配图片标签
    mvc 分页
    Asp.Net MVC4网站中自定义AuthorizeAttribute
    asp.net mvc4 身份验证问题无法绕过内置的Membership/Role机制
    HDU4712Hamming Distance随机化算法
  • 原文地址:https://www.cnblogs.com/8023spz/p/8920973.html
Copyright © 2011-2022 走看看