zoukankan      html  css  js  c++  java
  • 1064. Complete Binary Search Tree (30)

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:
    10
    1 2 3 4 5 6 7 8 9 0
    
    Sample Output:
    6 3 8 1 5 7 9 0 2 4
    

    没必要建树,直接用一个数组。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <map>
    using namespace std;
    int n,l[1001],tr[2010],c;
    void inorder(int k)
    {
        if(k > n)return;
        inorder(k * 2);
        tr[k] = l[c ++];
        inorder(k * 2 + 1);
    }
    void levelprint()
    {
        for(int i = 1;i <= n;i ++)
        {
            if(i == 1)printf("%d",tr[i]);
            else printf(" %d",tr[i]);
        }
    }
    int main()
    {
        scanf("%d",&n);
        for(int i = 0;i < n;i ++)
            scanf("%d",&l[i]);
        sort(l,l + n);
        inorder(1);
        levelprint();
    }
  • 相关阅读:
    周总结6
    河北省重大需求征集系统每日进度8
    《代码整洁之道》读书笔记3
    周总结5
    河北省重大需求征集系统每日进度7
    mybatis 关联查询多个类型相同对象
    thymeleaf 接受字符串类型model值作为js方法参数报错500
    毕业设计(2.17-2.23)周工作计划
    毕业设计记录——2.16
    毕业设计记录——2.15
  • 原文地址:https://www.cnblogs.com/8023spz/p/8994576.html
Copyright © 2011-2022 走看看