zoukankan      html  css  js  c++  java
  • poj 3617 Best Cow Line

    Description

    FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

    The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

    FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

    FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

    Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

    Input

    * Line 1: A single integer: N
    * Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

    Output

    The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

    Sample Input

    6
    A
    C
    D
    B
    C
    B

    Sample Output

    ABCBCD

    Source

     
    每次只能从已知序列头或者尾去掉一个字母,加在新的序列后面,要求新序列尽可能小,按字典序。
    贪心法,每次判断头尾,找出小的,如果相等,当然不能是两个任选,而是进一步判断最近的,因为要最小的先被加进新序列,比如CBAC,要把末尾的C加进去这样下一步就可加A,否则下一步加的就是B,不符合题意。
    代码:
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #define MAX 2002
    using namespace std;
    char s[MAX],t[MAX];
    int n;
    int check(int a,int b)
    {
        while(a < b && s[a] == s[b])///从头尾开始直到找到不相等的一对
        {
            a ++,b --;
        }
        return s[a] < s[b];///头小返回 1
    }
    void println(int a,int b)
    {
        for(int i = a;i < b;i ++)
            putchar(t[i]);
        putchar('
    ');
    }
    int main()
    {
        while(~scanf("%d",&n))
        {
            for(int i = 0;i < n;i ++)
            {
                getchar();
                scanf("%c",&s[i]);
            }
            int head = 0,tail = n - 1;///分别指向头尾
            while(head <= tail)
            {
                if(check(head,tail))///判断头尾哪边应该被去掉并加入新的序列
                {
                    t[n - 1 - tail + head] = s[head ++];
                }
                else
                {
                    t[n - 1 - tail + head] = s[tail --];
                }
            }
            for(int i = 0;i < n;i += 80)///每行最多输出80个 不然会presentation error 看清题意
            {
                println(i,min(n,i + 80));
            }
        }
    }
    View Code
  • 相关阅读:
    -Prefix.pch has been modified 的错误修复
    Xcode插件,模板安装
    php 内置函数JSON处理
    OC 创建单例
    UITabBarController 的配置
    execute、executeQuery和executeUpdate之间的区别
    iOS类方法实例方法 与 self
    iOS U7ea2 乱码 转换
    PHP 页面跳转的三种方式
    C#数组 动态添加元素
  • 原文地址:https://www.cnblogs.com/8023spz/p/9038410.html
Copyright © 2011-2022 走看看