zoukankan      html  css  js  c++  java
  • poj 2431 Expedition

    Description

    A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

    To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

    The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

    Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

    Input

    * Line 1: A single integer, N

    * Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

    * Line N+2: Two space-separated integers, L and P

    Output

    * Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

    Sample Input

    4
    4 4
    5 2
    11 5
    15 10
    25 10
    

    Sample Output

    2
    

    Hint

    INPUT DETAILS:

    The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

    OUTPUT DETAILS:

    Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

    Source

     
    从起点排着经过由近及远的stop,同时把经过的站的fuel存在优先队列里,起初表示在经过的stop都不停下来,当发现fuel不够时就从优先队列取较大的fuel值,然后出队,表示在此fuel值的stop停下来补充能量,当发现队列空了以后,fuel仍然不够时就输出-1,无法到达town,否则输出n-q.size(),停驻的stop都已经出队,剩下的是没有停的。
    代码:
    #include <iostream>
    #include <algorithm>
    #include <queue>
    #include <cstdio>
    using namespace std;
    struct stop
    {
        int distance,fuel;
    }s[10001];
    int n,l,p,flag;
    bool cmp(stop a,stop b)
    {
        return a.distance > b.distance;
    }
    int main()
    {
        priority_queue <int,vector<int>,less<int> > q;
        scanf("%d",&n);
        s[n].distance = s[n].fuel = 0;
        for(int i = 0;i < n;i ++)
        {
            scanf("%d%d",&s[i].distance,&s[i].fuel);
        }
        scanf("%d%d",&l,&p);
        sort(s,s + n,cmp);///按距离从大到小排,因为是距离town 的距离  所以越大的代表与起点越近
        for(int i = 0;i <= n;i ++)///s[n]的distance为0,代表终点 所以结果要 + 1  因为终点也入队了 ,多减了一下
        {
            while(p < l - s[i].distance && !q.empty())///p存fuel
            {
                p += q.top();
                q.pop();
            }
            if(p < l - s[i].distance){flag = -1;break;}///l存当前与town 的距离
            p -= l - s[i].distance;
            q.push(s[i].fuel);
            l = s[i].distance;
        }
        if(flag != -1)flag = n - q.size() + 1;
        printf("%d",flag);
    }
    View Code
  • 相关阅读:
    一个C++的unit库
    一篇关于如何组织unit tests的文章,很有趣
    web开发者的checklist
    用了story point就一定agile了吗?
    C#中如何用Windows Management Instrumentation (WMI)得到系统信息
    Windows下C++的同步机制的演变
    Sysinternals自动更新的工具SyncTools
    什么情况下要替换C++自带的new和delete
    VS2012插件:可视化TFS代码版本历史
    Quattro发布自助手机广告产品
  • 原文地址:https://www.cnblogs.com/8023spz/p/9054010.html
Copyright © 2011-2022 走看看