zoukankan      html  css  js  c++  java
  • hdu 1520 Anniversary party

    There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

    InputEmployees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
    L K
    It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
    0 0OutputOutput should contain the maximal sum of guests' ratings.
    Sample Input
    7
    1
    1
    1
    1
    1
    1
    1
    1 3
    2 3
    6 4
    7 4
    4 5
    3 5
    0 0
    Sample Output
    5

    树形dp,用邻接表存树,先把左右儿子解决了 然后再更新自己。
    代码:
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #define Max 6001
    using namespace std;
    int n,l[Max],k[Max];
    int rating[Max],fir[Max],nex[Max],vis[Max];
    int dp[2][Max];
    void dfs(int d)
    {
        int kk = fir[d];
        while(kk != -1)
        {
            dfs(l[kk]);
            dp[0][d] += max(dp[0][l[kk]],dp[1][l[kk]]);///当前点不出席的话 他的下一级出不出都可以
            dp[1][d] += dp[0][l[kk]];///他出席 下一级就不能出席
            kk = nex[kk];
        }
        dp[1][d] += rating[d];///出席需要加上rating
    }
    int main()
    {
        while(~scanf("%d",&n))
        {
            for(int i = 1;i <= n;i ++)
                scanf("%d",&rating[i]);
            memset(fir,-1,sizeof(fir));
            memset(dp,0,sizeof(dp));
            int i = 0;
            while(~scanf("%d%d",&l[i],&k[i]) && l[i] && k[i])
            {
                vis[l[i]] = 1;
                nex[i] = fir[k[i]];
                fir[k[i]] = i;
                i ++;
            }
            for(i = 1;i <= n;i ++)
            {
                if(!vis[i])
                {
                    dfs(i);
                    cout<<max(dp[0][i],dp[1][i])<<endl;
                }
                vis[i] = 0;
            }
        }
    }
    View Code
  • 相关阅读:
    Idea安装Mevn
    Spring_AOP
    Java_AOP原理
    Spring_数据校验和自定义检验规则和分组校验
    spring全局异常处理
    拦截器和自定义注解@interface
    linux下开启、关闭、重启mysql服务命令
    springboot的HelloWorld~~~
    切面自动装配注意点
    oracle分页
  • 原文地址:https://www.cnblogs.com/8023spz/p/9061406.html
Copyright © 2011-2022 走看看