zoukankan      html  css  js  c++  java
  • Cable master

    Description

    Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
    To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
    The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
    You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

    Input

    The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

    Output

    Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
    If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

    Sample Input

    4 11
    8.02
    7.43
    4.57
    5.39

    Sample Output

    2.00

    Source

     
    本来以为就是一道简单的二分,精度真是个大问题,要求的结果是个浮点数,二分的结束判断应该是根据差不超过一个限制,但是总是错误。书上让二分过程循环100次,直到解的范围最够小,最后输出保留两位,要把两位之后的完全切除掉,不能存在四舍五入。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    using namespace std;
    int n,k;
    double l,r;
    double s[10001];
    int sum(double t)
    {
        int c = 0;
        for(int i = 0;i < n;i ++)
            c += (int)(s[i] / t);
        return c;
    }
    int main()
    {
        scanf("%d%d",&n,&k);
        for(int i = 0;i < n;i ++)
        {
            scanf("%lf",&s[i]);
            r = max(r,s[i]);
        }
        int i = 0;
        while(i ++ <= 100)
        {
            double mid = (l + r) / 2;
            int su = sum(mid);
            if(su < k)r = mid;
            else l = mid;
        }
        printf("%.2f",(int)(l * 100) / 100.0);
    }

    还有一种方法是转换成整数。

  • 相关阅读:
    [BZOJ3160]万径人踪灭
    [BZOJ5212][ZJOI2018]历史
    [BZOJ3563&3569]DZY Loves Chinese
    [HDU4336]Card Collector
    [HDU4652]Dice
    [POJ3683]Priest John's Busiest Day
    ISODateTimeFormat 转换2019-08-15T00:36:49.366456463Z 日期格式
    GoTTY-K8S-Docker 终端
    【php】PHP对redis操作详解
    【tool】VLC播放rtmp协议
  • 原文地址:https://www.cnblogs.com/8023spz/p/9124177.html
Copyright © 2011-2022 走看看