zoukankan      html  css  js  c++  java
  • 1123 Is It a Complete AVL Tree(30 分)

    An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    F1.jpgF2.jpg
    F3.jpg F4.jpg

    Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print YES if the tree is complete, or NO if not.

    Sample Input 1:

    5
    88 70 61 63 65
    

    Sample Output 1:

    70 63 88 61 65
    YES
    

    Sample Input 2:

    8
    88 70 61 96 120 90 65 68
    

    Sample Output 2:

    88 65 96 61 70 90 120 68
    NO
    

    又是一道avl tree的题,好久不用纯c了,一直用c++,用纯c写一发,不画图写不出来。。。

    代码:

    #include <stdio.h>
    #include <stdlib.h>
    typedef struct tree tree;
    struct tree {
        int data;
        tree *left,*right;
    }*head = NULL;
    int n,d,flag = 1;
    int level[21];
    tree *create(int data) {///创建节点
        tree *t = (tree *)malloc(sizeof(tree));
        t -> left = t -> right = NULL;
        t -> data = data;
        return t;
    }
    int max_(int a,int b) {///最大值
        return a > b ? a : b;
    }
    int getheight(tree *t) {///求高度
        if(t == NULL)return 0;
        return max_(getheight(t -> left),getheight(t -> right)) + 1;
    }
    tree *ll(tree *t) {///左左旋
        tree *temp = t -> left;
        t -> left = temp -> right;
        temp -> right = t;
        return temp;
    }
    tree *rr(tree *t) {///右右旋
        tree *temp = t -> right;
        t -> right = temp -> left;
        temp -> left = t;
        return temp;
    }
    tree *lr(tree *t) {///左右旋
        t -> left = rr(t -> left);
        return ll(t);
    }
    tree *rl(tree *t) {///右左旋
        t -> right = ll(t -> right);
        return rr(t);
    }
    tree *insert_(tree *t,int data) {
        if(t == NULL)return create(data);
        else if(data > t -> data)t -> right = insert_(t -> right,data);
        else t -> left = insert_(t -> left,data);
        int a = getheight(t -> left),b = getheight(t -> right);
        if(a - b == 2) {///左边高
            if(data > t -> left -> data) {///插入的结点 在左子树的右子树
                t = lr(t);
            }
            else t = ll(t);///在左子树的左子树
        }
        else if(b - a == 2) {
            if(data < t -> right -> data) {///插入的结点 在右子树的左子树
                t = rl(t);
            }
            else t = rr(t);///在右子树的右子树
        }
        return t;
    }
    void level_order(tree *t) {///判断是否是完全二叉树
        tree *q[31] = {t},*p;
        int l = 0,r = 1;
        while(l < r) {
            p = q[l ++];
            level[l - 1] = p -> data;
            if(p -> left) {
                if(flag == 2)flag = 0;///之前有空结点 那么肯定不是完全二叉树
                q[r ++] = p -> left;
            }
            else if(flag == 1)flag = 2;///遇到空结点
            if(p -> right) {
                if(flag == 2)flag = 0;
                q[r ++] = p -> right;
            }
            else if(flag == 1)flag = 2;
        }
    }
    int main() {
        scanf("%d",&n);
        for(int i = 0;i < n;i ++) {
            scanf("%d",&d);
            head = insert_(head,d);
        }
        level_order(head);
        for(int i = 0;i < n;i ++) {
            if(i)putchar(' ');
            printf("%d",level[i]);
        }
        puts(flag ? "
    YES" : "
    NO");
    }
    
    
  • 相关阅读:
    C#获取当前路径的七种方法
    map容器对象插入数据的4种方式【转】
    为VMware虚拟机内安装的Ubuntu 16.04设置静态IP地址【转】
    Ubuntu16手动配置IP地址
    当前上下文不存在名称“***”
    C++读写文件ofstream,ifstream,fstream)[转]
    atoi()函数
    C++常用输出 cout、cerr、clog
    Lucene教程(转)
    selenium环境搭建1
  • 原文地址:https://www.cnblogs.com/8023spz/p/9278659.html
Copyright © 2011-2022 走看看