zoukankan      html  css  js  c++  java
  • poj 1088 滑雪

    Description

    Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
     1  2  3  4 5
    
    16 17 18 19 6
    15 24 25 20 7
    14 23 22 21 8
    13 12 11 10 9

    一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

    Input

    输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

    Output

    输出最长区域的长度。

    Sample Input

    5 5
    1 2 3 4 5
    16 17 18 19 6
    15 24 25 20 7
    14 23 22 21 8
    13 12 11 10 9
    

    Sample Output

    25

    Source

     
    dfs回溯。
    #include <stdio.h>
    #include <stdlib.h>
    #define inf 0x3f3f3f3f
    #define MAX 101
    int r,c,mp[MAX][MAX],ans;
    int vis[MAX][MAX],h[MAX][MAX];
    int dir[4][2] = {0,1,1,0,0,-1,-1,0};
    int max(int x,int y) {
        return x > y ? x : y;
    }
    void dfs(int x,int y) {
        vis[x][y] = 1;
        for(int i = 0;i < 4;i ++) {
            int tx = x + dir[i][0];
            int ty = y + dir[i][1];
            if(tx < 0 || ty < 0 || tx >= r || ty >= c)continue;
            if(mp[tx][ty] < mp[x][y]) {
                if(!vis[tx][ty]) dfs(tx,ty);
                h[x][y] = max(h[x][y],h[tx][ty]);
            }
        }
        h[x][y] ++;
    }
    int main() {
        scanf("%d%d",&r,&c);
        for(int i = 0;i < r;i ++) {
            for(int j = 0;j < c;j ++) {
                scanf("%d",&mp[i][j]);
            }
        }
        for(int i = 0;i < r;i ++) {
            for(int j = 0;j < c;j ++) {
                if(!vis[i][j])dfs(i,j);
                ans = max(ans,h[i][j]);
            }
        }
        printf("%d",ans);
    }
  • 相关阅读:
    Integer类_java_1
    Pytest使用随笔_1_"no tests ran"
    postgres执行计划_1_索引
    Jprofile使用随笔_2_内存泄漏
    leetcode76. Minimum Window Substring
    leetcode87. Scramble String
    hihocoder1310 岛屿
    leetcode644. Maximum Average Subarray II
    leetcode132. Palindrome Partitioning II
    leetcode143. Reorder List
  • 原文地址:https://www.cnblogs.com/8023spz/p/9322264.html
Copyright © 2011-2022 走看看