zoukankan      html  css  js  c++  java
  • poj 2376 Cleaning Shifts

    Description

    Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

    Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

    Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

    Input

    * Line 1: Two space-separated integers: N and T 

    * Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

    Output

    * Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

    Sample Input

    3 10
    1 7
    3 6
    6 10

    Sample Output

    2

    Hint

    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

    INPUT DETAILS: 

    There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

    OUTPUT DETAILS: 

    By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

    Source

     
    就是要把给出的时间段连在一起能够填满1-t即可,先排序,按开始时间从小到大排序,然后开始从第一个开始,d为起始时间,起始时间不超过d,找出结束时间最晚的,牛的数量加1,开始时间更新为这个最晚结束时间+1,然后重复这样的过程。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <map>
    #include <cstdlib>
    #include <algorithm>
    #define MAX 25001
    #define inf 0x3f3f3f3f
    using namespace std;
    typedef pair<int,int> pa;
    int n,t;
    pa p[MAX];
    
    int get() {
        int c = 0;
        int d = 1,i = 0;
        while(i < n && d <= t) {
            if(p[i].first > d)return -1;
            int te = 0;
            while(i < n && p[i].first <= d) {
                if(p[i].second > te)te = p[i].second;
                i ++;
            }
            c ++;
            d = te + 1;
        }
        if(d <= t)return -1;
        return c;
    }
    int main() {
        scanf("%d%d",&n,&t);
        for(int i = 0;i < n;i ++) {
            scanf("%d%d",&p[i].first,&p[i].second);
        }
        sort(p,p + n);
        printf("%d",get());
    }
  • 相关阅读:
    OpenMP并行编程
    visual studio 2005 编fortran程序,运行后dos窗口显示问题
    在fortran下进行openmp并行计算编程
    Intel Visual Fortran Compiler 11调用lapack库实现并行多处理计算
    C#数组的排序
    [转载]:Endnote 自定义style文件的默认位置
    正则表达式语法
    EFDC主控文件efdc.inp文件的xml格式化处理——转载http://blog.sina.com.cn/s/articlelist_1584892573_0_1.html
    Delphi 的绘图功能[1]
    根据点集合画曲线(贝塞尔)
  • 原文地址:https://www.cnblogs.com/8023spz/p/9516148.html
Copyright © 2011-2022 走看看