zoukankan      html  css  js  c++  java
  • poj 3176 Cow Bowling

    Description

    The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

              7
    

    3 8

    8 1 0

    2 7 4 4

    4 5 2 6 5
    Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

    Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

    Input

    Line 1: A single integer, N 

    Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

    Output

    Line 1: The largest sum achievable using the traversal rules

    Sample Input

    5
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30

    Hint

    Explanation of the sample: 

              7
    
    *
    3 8
    *
    8 1 0
    *
    2 7 4 4
    *
    4 5 2 6 5
    The highest score is achievable by traversing the cows as shown above.

    Source

    基础动态规划,每个数可以加到他下方相邻的两个数上,如此每个数可以加上上方相邻的两个数,选择大的那个。最后选择最大的。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    #include <cstdlib>
    #include <algorithm>
    #define MAX 351
    #define inf 0x3f3f3f3f
    using namespace std;
    int n;
    int s[MAX][MAX];
    int main() {
        scanf("%d",&n);
        for(int i = 1;i <= n;i ++) {
            for(int j = 1;j <= i;j ++) {
                scanf("%d",&s[i][j]);
                s[i][j] += max(s[i - 1][j],s[i - 1][j - 1]);
            }
        }
        int ans = 0;
        for(int i = 1;i <= n;i ++) {
            ans = max(ans,s[n][i]);
        }
        printf("%d",ans);
    }
  • 相关阅读:
    Java SE 基础之接口回顾
    读书杂谈-《架构探险:从零开始写Java Web框架》
    Java Se之类加载问题思考
    struts2 下载记录
    《重构改善既有代码的设计》笔记之序
    Luence简单实现2
    RabbitMQ学习(1):安装
    jquery插件dataTables添加序号列
    父<IFRAME>获取子页属性以及子页中<IFRAME>的方法
    类的约束 异常处理 自定义异常 MD5 日志信息处理
  • 原文地址:https://www.cnblogs.com/8023spz/p/9522817.html
Copyright © 2011-2022 走看看