zoukankan      html  css  js  c++  java
  • hdoj p1754——I Hate It(线段树)

    Problem Description
    很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
    这让很多学生很反感。

    不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
    Input
    本题目包含多组测试,请处理到文件结束。
    在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
    学生ID编号分别从1编到N。
    第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
    接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
    当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
    当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
    Output
    对于每一次询问操作,在一行里面输出最高成绩。
    Sample Input
    5 6
    1 2 3 4 5
    Q 1 5
    U 3 6
    Q 3 4
    Q 4 5
    U 2 9
    Q 1 5
    Sample Output
    5
    6
    5
    9

    线段树。。。框架基本相同,多的只有判断max了,在建树中加上就OK。

    #include<cstring>
    #define L(u) (u*2)
    #define R(u) (u*2+1)
    #define MAXN 200005
    using namespace std;
    int n,m;
    int a[MAXN];
    struct node{
      int l,r;
      int maxx;
    }s[MAXN*4];
    int ans=0;
    int max(int a,int b)
    {
      if(a>b)return a;
      return b;
    }
    void buildtree(int u,int left,int right)
    {
      s[u].l=left,s[u].r=right;
      if(left==right)
      {
        s[u].maxx=a[left];
        return ;
      }
      int mid=(s[u].l+s[u].r)>>1;
      buildtree(L(u),left,mid);
      buildtree(R(u),mid+1,right);
      s[u].maxx=max(s[L(u)].maxx,s[R(u)].maxx);
    }
    void pushup(int u)
    {
      s[u].maxx=max(s[L(u)].maxx,s[R(u)].maxx);
    }
    void update(int u,int x,int qwe)
    {
      if(s[u].l==x&&s[u].r==x)
      {
        s[u].maxx=qwe;
        return ;
      }
      int mid=(s[u].l+s[u].r)>>1;
      if(x>mid)update(R(u),x,qwe);
      else update(L(u),x,qwe);
      pushup(u);
    }
    void findmax(int u,int left,int right)
    {
      if(s[u].l==left&&s[u].r==right)
      {
        ans=max(ans,s[u].maxx);
        return ;
      }
      int mid=(s[u].l+s[u].r)>>1;
      if(left>mid)findmax(R(u),left,right);
      else if(right<=mid)findmax(L(u),left,right);
      else
      {
        findmax(L(u),left,mid);
        findmax(R(u),mid+1,right);
      }
    }
    int main()
    {
      ios::sync_with_stdio(false);
      while(cin>>n>>m)
      {
        memset(a,0,sizeof(a));
        memset(s,0,sizeof(s));
        for(int i=1;i<=n;i++)
        cin>>a[i];
        buildtree(1,1,n);
        for(int i=1;i<=m;i++)
        {
          char b;cin>>b;
          if(b=='Q')
          {
            ans=0;
            int x,y;cin>>x>>y;
            findmax(1,x,y);
            cout<<ans<<endl;
          }
          else

          {
            int x,y;cin>>x>>y;
            update(1,x,y);
          }
        }
      }
    }

  • 相关阅读:
    CF786E ALT
    CF704D Captain America
    [NOI2016]循环之美
    「PKUWC2018」猎人杀
    [HNOI2019]JOJO
    博客已转移
    $20200203$的数学作业
    20200202的数学作业
    NOIp 2016 选课 (DP)
    Luogu P2574 XOR的艺术 (线段树)
  • 原文地址:https://www.cnblogs.com/937337156Zhang/p/5668018.html
Copyright © 2011-2022 走看看