zoukankan      html  css  js  c++  java
  • PAT 1004. Counting Leaves

    PAT 1004. Counting Leaves (30)

    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
    Input

    Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    Output

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

    Sample Input

    2 1
    01 1 02
    

    Sample Output

    0 1
    

    分析

    树的遍历

    代码如下

    #include<iostream>
    #include<vector>
    using namespace std;
    vector<int> result(100,0);
    vector<int> vi[101];
    int maxdepth=-1;
    void dfs(int parent,int depth){
    	if(vi[parent].size()==0){
    		result[depth]++;
    		maxdepth=depth>maxdepth?depth:maxdepth;
    		return;
    	}
    	for(int i=0;i<vi[parent].size();i++)
    	dfs(vi[parent][i],depth+1);
    }
    int main(){
      int n,m,parent,num,child;
      cin>>n>>m;
      for(int i=0;i<m;i++){
      	cin>>parent>>num;
      	for(int j=0;j<num;j++){
      		cin>>child;
      		vi[parent].push_back(child);
    	  }
      }
      dfs(1,0);
      for(int i=0;i<=maxdepth;i++)
      i>0?cout<<" "<<result[i]:cout<<result[i];
      return 0;	
    } 
    
  • 相关阅读:
    torrent&BT百科
    网页flv下载探索_1
    u-boot FIT image介绍_转自“蜗窝科技”
    28个Unix/Linux的命令行神器_转
    程序员的“纪律性”_转自“蜗窝科技”
    “极致”神话和产品观念_转自“蜗窝科技”
    制作自己的嵌入式Linux电脑_转
    buildroot--uboot&kernel&rootfs全编译工具
    (转)编码规范系列(一):Eclipse Code Templates设置
    matlab图片清晰度调整
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8185431.html
Copyright © 2011-2022 走看看