zoukankan      html  css  js  c++  java
  • PAT 1007. Maximum Subsequence Sum

    PAT 1007. Maximum Subsequence Sum (25)

    Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4
    

    分析

    max为要求的最大和,sum为临时最大和,first和last为所求的子序列的下标,s标记first的临时下标。
    sum=sum+ vi[i],当sum比max大,就更新max的值、first和last的值;当sum < 0,那么后面不管来什么值,都应该舍弃sum < 0前面的内容,因为负数对于总和只可能拉低总和,不可能增加总和,还不如舍弃;
    舍弃后,直接令sum = 0,并且同时更新first的临时值s。

    代码如下

    #include<iostream>
    #include<vector>
    using namespace std;
    int main(){
    	int N;
    	cin>>N;
    	vector<int> vi(N,0);
    	int sum=0,s=0,max=-1,first=0,last=N-1;
    	for(int i=0;i<N;i++){
    		cin>>vi[i];
    	    sum+=vi[i];
    		if(sum<0){
    			s=i+1;
    			sum=0;
    		}else if(sum>max){
            	first=s;
            	last=i;
            	max=sum;
    		}
    	}
    	max=max<0?0:max;
    	cout<<max<<" "<<vi[first]<<" "<<vi[last];
    	return 0;
    }
    
  • 相关阅读:
    多层感知机的简洁实现
    汇编语言总结(1)
    回顾下TCP/IP协议
    五笔输入法的前世今生
    大O算法
    算法基础概念
    TCP和UDP的区别
    数据结构基本概念和术语
    gdb调试方法
    GD32F20x系列使用问题总结
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8191645.html
Copyright © 2011-2022 走看看