zoukankan      html  css  js  c++  java
  • PAT 1008. Elevator

    PAT 1008. Elevator (20)

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:

    3 2 3 1
    

    Sample Output:

    41
    

    代码如下

    #include<iostream>
    #include<vector>
    using namespace std;
    int main(){
         int N,nextfloor,lastfloor=0,time=0;
         cin>>N;
         for(int i=0;i<N;i++){
         	cin>>nextfloor;
         	time+=(nextfloor>lastfloor?6*(nextfloor-lastfloor):4*(lastfloor-nextfloor));
         	lastfloor=nextfloor;
    	 }
         cout<<time+N*5;
    }
    
  • 相关阅读:
    120.三角形最短路径(leetcode)
    Python Pycharm中灵活运用debugger
    POJ 1284
    POJ 2407
    POJ 1811
    HDU 1164
    HDU 4228
    HDU 2521
    HDU 4133
    ZOJ 2562 反素数
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8191896.html
Copyright © 2011-2022 走看看