zoukankan      html  css  js  c++  java
  • PAT 1019. General Palindromic Number

    PAT 1019. General Palindromic Number

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

    Sample Input 1:

    27 2
    

    Sample Output 1:

    Yes
    1 1 0 1 1
    

    Sample Input 2:

    121 5
    

    Sample Output 2:

    No
    4 4 1
    

    代码如下

    #include<iostream>
    using namespace std;
    int main(){
    	int N,b,index=0,arr[50],flag=0;
    	cin>>N>>b;
    	while(N!=0){
    		arr[index++]=N%b;
    		N/=b;
    	}
    	for(int i=0;i<index/2;i++)
    	if(arr[i]!=arr[index-i-1]){
    		flag=1;
    		break;
    	}
    	flag>0?cout<<"No"<<endl:cout<<"Yes"<<endl;
    	for(int i=index-1;i>=0;i--)
    	if(i==index-1) cout<<arr[i];
    	else cout<<" "<<arr[i];
    	if(index==0) cout<<"0"; 
    } 
    
  • 相关阅读:
    JS练习
    推断一组数的规律,并填充缺失的数
    IP地址的正则表达式写法
    相比于HTML4,HTML5废弃的元素有哪些?
    关于HTML5和CSS3的几个“新增”
    hdu 3092 简单数论+分组背包dp
    避障
    人工势场法
    A*
    pop 2049-简单bfs
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8231969.html
Copyright © 2011-2022 走看看