zoukankan      html  css  js  c++  java
  • PAT 1025. PAT Ranking

    Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

    registration_number final_rank location_number local_rank

    The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

    Sample Input:
    2
    5
    1234567890001 95
    1234567890005 100
    1234567890003 95
    1234567890002 77
    1234567890004 85
    4
    1234567890013 65
    1234567890011 25
    1234567890014 100
    1234567890012 85
    Sample Output:
    9
    1234567890005 1 1 1
    1234567890014 1 2 1
    1234567890001 3 1 2
    1234567890003 3 1 2
    1234567890004 5 1 4
    1234567890012 5 2 2
    1234567890002 7 1 5
    1234567890013 8 2 3
    1234567890011 9 2 4

    分析
    这道题用了STL的sort函数和自定义的cmp来排序,其他的还行;

    #include<iostream>
    #include<algorithm>
    using namespace std;
    struct testee{
    	string id;
    	int score,location_num,local_rank,final_rank;
    };
    bool cmp(testee t1,testee t2){
    	return t1.score!=t2.score?t1.score>t2.score:t1.id<t2.id; 
    }
    int main(){
    	int N,sum,K;
    	cin>>N;
    	vector<testee> vi;
    	for(int i=0;i<N;i++){
    		cin>>K;
    		vector<testee> t(K);
    		for(int j=0;j<K;j++){
    		    cin>>t[j].id>>t[j].score;
    		    t[j].location_num=i+1;
    		}
    		sort(t.begin(),t.end(),cmp);
    		t[0].local_rank=1;
    		vi.push_back(t[0]);
    		for(int j=1;j<t.size();j++){
    			t[j].local_rank=(t[j].score<t[j-1].score?j+1:t[j-1].local_rank);
    			vi.push_back(t[j]);
    		}	   
    	}
        sort(vi.begin(),vi.end(),cmp);
        vi[0].final_rank=1;
        for(int j=1;j<vi.size();j++)
    		vi[j].final_rank=vi[j].score<vi[j-1].score?j+1:vi[j-1].final_rank;
    	cout<<vi.size()<<endl;
        for(int i=0;i<vi.size();i++)
            cout<<vi[i].id<<" "<<vi[i].final_rank<<" "<<vi[i].location_num<<" "<<vi[i].local_rank<<endl;
        return 0;    
    }
    
  • 相关阅读:
    docker 第六篇 dockerfile
    docker 第五篇 存储
    8.4总结
    消失之物,分治
    NOIP模拟9
    卡特兰数总结
    【洛谷】P3537 [POI2012]SZA-Cloakroom
    0915 N校联考
    [树链剖分]BZOJ3589动态树
    0905膜你赛测试
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8289084.html
Copyright © 2011-2022 走看看