zoukankan      html  css  js  c++  java
  • PAT 1036. Boys vs Girls

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

    Sample Input 1:
    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95

    Sample Output 1:
    Mary EE990830
    Joe Math990112
    6

    Sample Input 2:
    1
    Jean M AA980920 60

    Sample Output 2:
    Absent
    Jean AA980920
    NA

    这道题好像也没什么好说的

    #include<iostream>
    using namespace std;
    int main(){
    	int n,lowest=101,highest=-1,grade;
    	string name,lname,lid,hname,hid,gender,id;
    	cin>>n;
    	for(int i=0;i<n;i++){
    		cin>>name>>gender>>id>>grade;
    		if(gender=="F"&&grade>highest){
    			hname=name;
    			hid=id;
    			highest=grade;
    		}else if(gender=="M"&&grade<lowest){
    			lname=name;
    			lid=id;
    			lowest=grade;
    		}
    	}
    	highest>-1?cout<<hname<<" "<<hid<<endl:cout<<"Absent"<<endl;
    	lowest<101?cout<<lname<<" "<<lid<<endl:cout<<"Absent"<<endl;
    	if(highest!=-1&&lowest!=101)
    	cout<<highest-lowest<<endl;
    	else cout<<"NA"<<endl;
    	return 0; 
    } 
    
  • 相关阅读:
    @Autowired mapper 层次 bean 带红线
    java 类加载机制 阿里面试题
    liunx 修改ssh 端口22
    通过mysqlbinlog 恢复数据
    网页命名规则
    子选择符 、相邻选择符 、 兄弟选择符 、 伪类选择符
    css的一些基础知识
    HTML5的表单所有type类型
    一行代码解决各种IE兼容问题,IE6,IE7,IE8,IE9,IE10(复制)
    网站开发最常用的代码(复制)
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8301283.html
Copyright © 2011-2022 走看看