zoukankan      html  css  js  c++  java
  • PAT 1061. Dating

    Sherlock Holmes received a note with some strange strings: "Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm". It took him only a minute to figure out that those strange strings are actually referring to the coded time "Thursday 14:04" -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter 'D', representing the 4th day in a week; the second common character is the 5th capital letter 'E', representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is 's' at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

    Input Specification:

    Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

    Output Specification:

    For each test case, print the decoded time in one line, in the format "DAY HH:MM", where "DAY" is a 3-character abbreviation for the days in a week -- that is, "MON" for Monday, "TUE" for Tuesday, "WED" for Wednesday, "THU" for Thursday, "FRI" for Friday, "SAT" for Saturday, and "SUN" for Sunday. It is guaranteed that the result is unique for each case.

    Sample Input:

    3485djDkxh4hhGE 
    2984akDfkkkkggEdsb 
    s&hgsfdk 
    d&Hyscvnm
    

    Sample Output:
    THU 14:04

    #include<iostream>
    #include<map>
    #include<algorithm>
    #include<string.h> 
    #include<iomanip>
    using namespace std;
    int main(){
        string s1,s2,s3,s4;
        string Day,Hour;
        int flag=0,min;
        cin>>s1>>s2>>s3>>s4;
        map<char,string> day={{'A',"MON"},{'B',"TUE"},{'C',"WED"},
                            {'D',"THU"},{'E',"FRI"},{'F',"SAT"},{'G',"SUN"}};
        map<char,string> hour={{'0',"00:"},{'1',"01:"},{'2',"02:"},{'3',"03:"},
                            {'4',"04:"},{'5',"05:"},{'6',"06:"},{'7',"07:"},
                            {'8',"08:"},{'9',"09:"},{'A',"10:"},{'B',"11:"},{'C',"12:"},
                            {'D',"13:"},{'E',"14:"},{'F',"15:"},{'G',"16:"},{'H',"17:"},
                            {'I',"18:"},{'J',"19:"},{'K',"20:"},{'L',"21:"},{'M',"22:"},
                            {'N',"23:"}};                    
        int l=s1.length()<s2.length()?s1.length():s2.length();
        for(int i=0;i<l;i++){
            if(flag==0&&s1[i]==s2[i]&&day.find(s1[i])!=day.end()){
    		    Day=day[s1[i]]; 
    			flag++; i++;
    		}
            if(flag==1&&s1[i]==s2[i]&&hour.find(s1[i])!=hour.end()){
    		    Hour=hour[s1[i]]; 
    			break;
    		}
        }
        l=s3.length()<s4.length()?s3.length():s4.length();
        for(int i=0;i<l;i++){
            if(s3[i]==s4[i]&&isalpha(s3[i])){
    		   min=i; break;
    		}
        }
        cout<<Day<<" "<<Hour<<setw(2)<<setfill('0')<<min;            
        return 0; 
    }
    
  • 相关阅读:
    python 迭代器&&生成器
    windows 10 扩大C盘空间
    robot framework 接口自动化测试和关键字开发
    Robot framework 环境搭建+图标处理
    Docker 安装-在centos7下安装Docker(二)
    win10系统rational rose 安装后打开弹框显示java.lang.ClassNotFoundException 解决方案
    mysql 关系表 分组读取的方法
    关于浮点型计算遇到的小问题
    dom 的介绍
    网站前端相关的知识点
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8366014.html
Copyright © 2011-2022 走看看