zoukankan      html  css  js  c++  java
  • PAT 1076. Forwards on Weibo

    Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

    M[i] user_list[i]

    where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

    Then finally a positive K is given, followed by K UserID's for query.

    Output Specification:

    For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

    Sample Input:

    7 3
    3 2 3 4
    0
    2 5 6
    2 3 1
    2 3 4
    1 4
    1 5
    2 2 6

    Sample Output:

    4
    5

    分析

    考察BFS,即通过题目先建图,然后数出给定层数内的点的个数,本身给的那个点不能算, 至于层数的变化是通过last和tail来控制的。

    #include<iostream>
    #include<queue>
    #include<algorithm>
    using namespace std;
    int main(){
    	int n,l,no,p;;
    	cin>>n>>l;
    	int G[n+1][n+1],visited[n+1]={0};
    	fill(G[0],G[0]+(n+1)*(n+1),0);
    	for(int i=1;i<=n;i++){
    		cin>>no;
    		for(int j=0;j<no;j++){
    			cin>>p;
    			G[p][i]=1;
    		}
    	}
    	cin>>no;
    	for(int i=0;i<no;i++){
    		cin>>p;
    		fill(visited,visited+n+1,0);
    		queue<int> q;
    		q.push(p);
    		visited[p]=1;
    		int cnt=0,level=0,last=p,tail;
    		while(!q.empty()&&level<l){
    			int temp=q.front();
    			q.pop();
    			for(int j=1;j<=n;j++)
    			   if(visited[j]==0&&G[temp][j]==1){
    			   	  q.push(j);
    			   	  tail=j;
    			   	  cnt++;
    			   	  visited[j]=1;
    			   }	      
    		    if(last==temp){
    			   level++;
    			   last=tail;
    		    }
    		}
    		cout<<cnt<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    μTorrent for Windows
    坚决抵制Rarbg的恶意修改版
    Check YouTube Video Restrictions Online
    Questions about "Computer Systems: A Programmer's Perspective"
    los diccionarios que te acercan al mundo
    sqlserver 备份数据库 按时间命名备份文件
    Linux中的硬链接和软链接的概念、区别及用法
    高恪固件端口映射怎么配置
    C++中的DLL,Delphi调用需要注意之一
    Delphi中主线程与子线程调用同一方法同步问题
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8401003.html
Copyright © 2011-2022 走看看