zoukankan      html  css  js  c++  java
  • PAT 1092. To Buy or Not to Buy

    Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is "Yes", please tell her the number of extra beads she has to buy; or if the answer is "No", please tell her the number of beads missing from the string.

    For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

         

                  Figure 1
    Input Specification:

    Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

    Output Specification:

    For each test case, print your answer in one line. If the answer is "Yes", then also output the number of extra beads Eva has to buy; or if the answer is "No", then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

    Sample Input 1:

    ppRYYGrrYBR2258
    YrR8RrY

    Sample Output 1:

    Yes 8

    Sample Input 2:

    ppRYYGrrYB225
    YrR8RrY

    Sample Output 1:

    No 2

    #include<iostream>
    using namespace std;
    int main(){
        string s1,s2;
        cin>>s1>>s2;
        int a[123]={0},less=0,more=0;
        for(int i=0;i<s1.size();i++)
            a[s1[i]]++;
        for(int i=0;i<s2.size();i++)
            a[s2[i]]--;
        for(int i=1;i<123;i++)
            if(a[i]<0) less+=a[i];
            else more+=a[i];
        if(less<0) cout<<"No "<<-less<<endl;
        else cout<<"Yes "<<more<<endl;
        return 0;
    } 
    
    
  • 相关阅读:
    10.25T2 二维线段树
    10.25T1 模拟+栈
    10.24T3 解方程 取模意义下运算+秦九韶算法
    10.24T2 树链剖分
    10.24T1 树形DP
    10.23T3 杨辉三角上做莫队
    10.23T2 二分+二分图(滑稽)
    10.23T1 杨辉三角
    10.22T6 水题
    10.22T4 模拟DP
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8416389.html
Copyright © 2011-2022 走看看