zoukankan      html  css  js  c++  java
  • PAT 1100. Mars Numbers

    People on Mars count their numbers with base 13:

    Zero on Earth is called "tret" on Mars.
    The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
    For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.
    For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (< 100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

    Output Specification:

    For each number, print in a line the corresponding number in the other language.

    Sample Input:

    4
    29
    5
    elo nov
    tam

    Sample Output:

    hel mar
    may
    115
    13

    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<sstream>
    using namespace std;
    int main(){
        vector<string> gewei{"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
        vector<string> shiwei{"#","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};
        int N; cin>>N;
        string s,str; int a,b,c;
        getchar();
        while(N--){
            int sum=0;
            getline(cin,s);
            if(isdigit(s[0])){
               c=stoi(s); // 将s转化为int
            if(c<13)  
    		   cout<<gewei[c]<<endl;
            else{
                if(c%13==0) cout<<shiwei[c/13]<<endl; // 13的倍数是不要输出tret的
                else cout<<shiwei[c/13]<<" "<<gewei[c%13]<<endl;
                }
            }
            else{
                istringstream is(s); // 利用istringstream读取s中的单词
                while(is>>str){
                    auto it=find(shiwei.begin(),shiwei.end(),str);
                    if(it!=shiwei.end())
                       sum+=(it-shiwei.begin())*13;
                    auto itt=find(gewei.begin(),gewei.end(),str);
                    if(itt!=gewei.end())
                       sum+=(itt-gewei.begin());
                }
                cout<<sum<<endl; 
            }
        }
        return 0;
    }
    
  • 相关阅读:
    解决App can’t be opened because it is from an unidentified developer
    Mac之当前目录打开终端
    Mac之安装zsh
    毕业论文之降低重复率
    Latex之希腊字母表 花体字母 实数集
    latex之插入数学公式
    好句收集
    Python之两个列表一起打乱
    Python之时间统计
    Python之正则表达式
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8430028.html
Copyright © 2011-2022 走看看