zoukankan      html  css  js  c++  java
  • PAT 1106 Lowest Price in Supply Chain

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

    Input Specification:
    Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10^5), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki ID[1] ID[2] ... ID[Ki]

    where in the i-th line, Ki​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

    Output Specification:
    For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10^​10.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0
    2 6 1
    1 8
    0
    0
    0

    Sample Output:

    1.8362 2

    #include<iostream> //类似于树的层级遍历
    #include<vector>
    #include<iomanip>
    #include<math.h>
    using namespace std;
    int minlevel=9999999, num=0;
    void level_traversal(vector<vector<int>> &chain, int level, int root){
      if(chain[root].size()!=0){
        for(int i=0; i<chain[root].size(); i++)
            level_traversal(chain, level+1, chain[root][i]);
      }else{
        if(minlevel>level){
          minlevel=level;
          num=1;
        }else if(minlevel==level)
          num++;
      }
    }
    int main(){
      int N;
      double p, r;
      cin>>N>>p>>r;
      vector<vector<int>> chain;
      for(int i=0; i<N; i++){
        int n;
        cin>>n;
        vector<int> temp(n,0);
        for(int j=0; j<n; j++)
          cin>>temp[j];
        chain.push_back(temp);
      }
      level_traversal(chain, 0, 0);
      cout<<setiosflags(ios::fixed)<<setprecision(4)<<p*pow(1+0.01*r, minlevel);
      cout<<" "<<num<<endl;
      return 0;
    }
    
  • 相关阅读:
    关于Java 拷贝数组方法 Arrays.copyOf() 是地址传递还是值传递
    n皇后问题
    子集
    排列
    矩阵翻转
    删除集合元素的方法
    Java最大值与最小值
    Spring Security +Oauth2 +Spring boot 动态定义权限
    VirtualBox Centos7虚拟机集群配置
    VirtualBox使用Centos7与主机共享文件夹
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9501888.html
Copyright © 2011-2022 走看看