zoukankan      html  css  js  c++  java
  • PAT 1112 Stucked Keyboard

    On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

    Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

    Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

    Input Specification:
    Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

    Output Specification:
    For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

    Sample Input:
    3
    caseee1__thiiis_iiisss_a_teeeeeest

    Sample Output:
    ei
    case1__this_isss_a_teest

    #include<iostream>
    #include<map>
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main(){
      int times, t=0;
      string s;
      cin>>times>>s;
      char c=s[0];
      map<char, int> bkey;
      vector<char> ans;
      for(int i=0; i<s.size(); i++){
        if(s[i]==c){
          t++;
        }else{
          if(t%times==0&&bkey[c]==0){
             ans.push_back(c);
             bkey[c]=2;
          }
          else if(t%times!=0){
          	 if(bkey[c]==2)
          	 	ans.erase(find(ans.begin(), ans.end(), c));
             bkey[c]=1;
          }
    	  c=s[i];
          t=1;
        }
      }
      if(t%times==0&&bkey[c]==0){
      	ans.push_back(c);
      	bkey[c]=2;
      }
      for(int i=0; i<ans.size(); i++)
        cout<<ans[i];
      cout<<endl;
      for(int i=0; i<s.size(); i++){
        cout<<s[i];
        if(bkey[s[i]]==2)
        	i+=times-1;
      }
      return 0;
    }
    
  • 相关阅读:
    C#调用默认浏览器打开网页的几种方法
    关于百度排名点击器作弊提升百度排名的说明
    网站被百度降权的各种原因大解析
    百度搜索引擎排名原理、因素
    【ASP.NET开发】获取客户端IP地址 via C#
    防抖和节流
    vuex
    watch 和 computed
    JavaScript捕获与冒泡与委托
    XSS攻击
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9501992.html
Copyright © 2011-2022 走看看