zoukankan      html  css  js  c++  java
  • PAT 1120 Friend Numbers

    Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

    Input Specification:
    Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10^4 .

    Output Specification:
    For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

    Sample Input:
    8
    123 899 51 998 27 33 36 12

    Sample Output:
    4
    3 6 9 26

    #include<iostream> //水题
    #include<set>
    using namespace std;
    int main(){
      int n;
      cin>>n;
      set<int> ans;
      for(int i=0; i<n; i++){
        string s;
        cin>>s;
        int sum=0;
        for(int j=0; j<s.size(); j++)
          sum+=s[j]-'0';
        ans.insert(sum);
      }
      cout<<ans.size()<<endl;
      cout<<*ans.begin();
      for(auto it=++ans.begin(); it!=ans.end(); it++)
        cout<<" "<<*it;
      cout<<endl;
      return 0;
    }
    
  • 相关阅读:
    牛客(28)数组中出现次数超过一半的数字
    牛客(27)字符串的排列
    2、Spring Cloud和dubbo简介
    1、微服务简介
    12、Spring Boot监控
    11、Spring Boot热部署
    10、Spring Boot分布式
    9、Spring Boot安全
    8、Spring Boot任务
    7、Spring Boot检索
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9502078.html
Copyright © 2011-2022 走看看