zoukankan      html  css  js  c++  java
  • PAT 1130 Infix Expression

    Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

    data left_child right_child

    where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

    infix1.JPG
    Figure 1

    infix2.JPG
    Figure 2

    Output Specification:

    For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

    Sample Input 1:

    8
    * 8 7
    a -1 -1
    * 4 1
    + 2 5
    b -1 -1
    d -1 -1
    - -1 6
    c -1 -1
    

    Sample Output 1:

    (a+b)*(c*(-d))
    

    Sample Input 2:

    8
    2.35 -1 -1
    * 6 1
    - -1 4
    % 7 8
    + 2 3
    a -1 -1
    str -1 -1
    871 -1 -1
    

    Sample Output 2:

    (a*2.35)+(-(str%871))
    
    #include<iostream> //海星,建树然后中序遍历
    #include<vector>
    using namespace std;
    struct node{
    	string val;
    	node* left;
    	node* right;
    	node(string v):val(v), left(NULL), right(NULL){
    	}
    };
    vector<int> lc, rc;
    vector<string> data;
    node* buildtree(node* root, int r){
    	root=new node(data[r]);
    	if(lc[r]!=-1)
    		root->left=buildtree(root->left, lc[r]);
    	if(rc[r]!=-1)
    		root->right=buildtree(root->right, rc[r]); 
    	return root;
    }
    void solution(node* root, int flag){
    	if((root->left||root->right)&&flag) 
    	cout<<"(";
    	if(root->left)
    		solution(root->left, 1);
    	cout<<root->val;
    	if(root->right)
    		solution(root->right, 1);
    	if((root->left||root->right)&&flag) 
    	cout<<")";
    }
    int main(){
    	int n;
    	cin>>n;
    	vector<int> visited(n+1, 0);
    	lc.resize(n+1), rc.resize(n+1);
    	data.resize(n+1);
    	for(int i=1; i<=n; i++){
    		int l, r;
    		cin>>data[i]>>l>>r;
    		lc[i]=l;
    		rc[i]=r;
    		if(l!=-1) visited[l]=1;
    		if(r!=-1) visited[r]=1;
    	}
    	int i;
    	for(i=1; i<=n; i++)
    		if(visited[i]==0)
    			break;
    	node* root=NULL;
    	root=buildtree(root ,i);
    	solution(root, 0);
    	return 0;
    } 
    
  • 相关阅读:
    encodeURIComponent与encodeURI的区别
    css实现强制不换行/自动换行/强制换行
    浏览器的visibilitychange 事件ie10以下不兼容
    判断IE版本的语句 [if lte IE 6]...[endif]
    jQueryr .on方法解析
    js判断IE6(推荐方法一)
    JS判断设备终端(PC,iPad,iPhone,android,winPhone)和浏览器
    js判断手机浏览器
    js数字格式化-四舍五入精简版
    jQuery scroll(滚动)延迟加载
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9506682.html
Copyright © 2011-2022 走看看