zoukankan      html  css  js  c++  java
  • uva

    Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N <tex2html_verbatim_mark>(1 < N < 10000) <tex2html_verbatim_mark>. After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 <tex2html_verbatim_mark>, the sequence is:

    12345678910111213

    In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

    Input 

    The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

    For each test case, there is one single line containing the number N <tex2html_verbatim_mark>.

    Output 

    For each test case, write sequentially in one line the number of digit 0, 1,...9 <tex2html_verbatim_mark>separated by a space.

    Sample Input 

    2 
    3 
    13
    

    Sample Output 

    0 1 1 1 0 0 0 0 0 0 
    1 6 2 2 1 1 1 1 1 1

    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner in = new Scanner(System.in);
            int n = in.nextInt();
            for (int i = 0; i < n; i++) {
                int m = in.nextInt();
                String s = "";
                for (int j = 1; j <= m; j++)
                    s = s.concat(j + "");
    
                int[] ch = new int[10];
                for (int j = 0; j < s.length(); j++) {
                    if (s.charAt(j) == '0')
                        ch[0]++;
                    else if (s.charAt(j) == '1')
                        ch[1]++;
                    else if (s.charAt(j) == '2')
                        ch[2]++;
                    else if (s.charAt(j) == '2')
                        ch[2]++;
                    else if (s.charAt(j) == '3')
                        ch[3]++;
                    else if (s.charAt(j) == '4')
                        ch[4]++;
                    else if (s.charAt(j) == '5')
                        ch[5]++;
                    else if (s.charAt(j) == '6')
                        ch[6]++;
                    else if (s.charAt(j) == '7')
                        ch[7]++;
                    else if (s.charAt(j) == '8')
                        ch[8]++;
                    else if (s.charAt(j) == '9')
                        ch[9]++;
    
                }
                for (int j = 0; j <= 9; j++) {
                    System.out.print(ch[j]);
                    if (j != 9)
                        System.out.print(" ");
                }
                System.out.println();
            }
        }
    }
  • 相关阅读:
    520 简单表白代码(JS)
    2017总结+展望2018
    JavaScript中标识符的命名
    ubuntu16.04 CUDA, CUDNN 安装
    Educational Codeforces Round 46 (Rated for Div. 2) D. Yet Another Problem On a Subsequence
    Codeforces Round #489 (Div. 2) E. Nastya and King-Shamans
    AtCoder Regular Contest 098 F.Donation
    hackerrank Project Euler #210: Obtuse Angled Triangles
    论文阅读 | CrystalBall: A Visual Analytic System for Future Event Discovery and Analysis from Social Media Data
    python学习笔记5
  • 原文地址:https://www.cnblogs.com/ABC-00/p/5475442.html
Copyright © 2011-2022 走看看