zoukankan      html  css  js  c++  java
  • uva

    Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N <tex2html_verbatim_mark>(1 < N < 10000) <tex2html_verbatim_mark>. After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 <tex2html_verbatim_mark>, the sequence is:

    12345678910111213

    In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

    Input 

    The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

    For each test case, there is one single line containing the number N <tex2html_verbatim_mark>.

    Output 

    For each test case, write sequentially in one line the number of digit 0, 1,...9 <tex2html_verbatim_mark>separated by a space.

    Sample Input 

    2 
    3 
    13
    

    Sample Output 

    0 1 1 1 0 0 0 0 0 0 
    1 6 2 2 1 1 1 1 1 1

    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner in = new Scanner(System.in);
            int n = in.nextInt();
            for (int i = 0; i < n; i++) {
                int m = in.nextInt();
                String s = "";
                for (int j = 1; j <= m; j++)
                    s = s.concat(j + "");
    
                int[] ch = new int[10];
                for (int j = 0; j < s.length(); j++) {
                    if (s.charAt(j) == '0')
                        ch[0]++;
                    else if (s.charAt(j) == '1')
                        ch[1]++;
                    else if (s.charAt(j) == '2')
                        ch[2]++;
                    else if (s.charAt(j) == '2')
                        ch[2]++;
                    else if (s.charAt(j) == '3')
                        ch[3]++;
                    else if (s.charAt(j) == '4')
                        ch[4]++;
                    else if (s.charAt(j) == '5')
                        ch[5]++;
                    else if (s.charAt(j) == '6')
                        ch[6]++;
                    else if (s.charAt(j) == '7')
                        ch[7]++;
                    else if (s.charAt(j) == '8')
                        ch[8]++;
                    else if (s.charAt(j) == '9')
                        ch[9]++;
    
                }
                for (int j = 0; j <= 9; j++) {
                    System.out.print(ch[j]);
                    if (j != 9)
                        System.out.print(" ");
                }
                System.out.println();
            }
        }
    }
  • 相关阅读:
    属性的简单了解
    深入方法(29)- 传址参数不能赋予常量
    深入方法(27)- 递归函数: 简单示例
    MySQL 中文字符集排序
    Yii2 Apache + Nginx 路由重写
    DQL、DML、DDL、DCL的概念与区别
    php获取指定日期的前一天,前一月,前一年日期
    PHP 获取两个时间之间的月份
    PHP 调试工具Xdebug安装配置
    Nginx 反向代理、负载均衡
  • 原文地址:https://www.cnblogs.com/ABC-00/p/5475442.html
Copyright © 2011-2022 走看看