zoukankan      html  css  js  c++  java
  • hdu 1002 A+B problem II

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002

    题目分析:高精度问题,大整数相加。 由此题可见java相较于C/C++的优势,即丰富多彩的类以及强大的字符串/IO处理机制。调用BigeInteger类,减少了太多麻烦~~

    /*A + B Problem II
    
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 237263    Accepted Submission(s): 45690
    
    
    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     
    
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     
    
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     
    
    Sample Input
    2
    1 2
    112233445566778899 998877665544332211
     
    
    Sample Output
    Case 1:
    1 + 2 = 3
    
    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110
     
    
    Author
    Ignatius.L
     
    */
    // BigInteger
    import java.util.*;
    import java.math.*;
    public class Main {
    
        public static void main(String[] args) {
            // TODO Auto-generated method stub
            Scanner in = new Scanner(System.in);
            BigInteger a, b;
            int n = in.nextInt();
            for(int i = 1; i <= n; i++){
                a = in.nextBigInteger();
                b = in.nextBigInteger();
                System.out.println("Case "+i+":");
                System.out.println(a+" + "+b+" = "+a.add(b));
                if(i != n) System.out.println();
            }
        }
    
    }
  • 相关阅读:
    暑假学习笔记(一)——初识Neo4j和APICloud入门
    置信规则库学习记录——1
    博客整理——宣传文案
    博客整理——软件工程实践总结
    博客整理——Alpha版冲刺
    博客整理——事后诸葛亮
    面试被企业拒绝后还有必要再申请吗?
    MapReduce分布式算法
    水题系列二:PhoneNumbers
    水题系列一:Circle
  • 原文地址:https://www.cnblogs.com/ACFLOOD/p/4279193.html
Copyright © 2011-2022 走看看