zoukankan      html  css  js  c++  java
  • Sightseeing trip

    Sightseeing trip

    Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

    Description

    There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

    In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

    Input

    The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

    Output

    There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

    Sample Input

    5 7
    1 4 1
    1 3 300
    3 1 10
    1 2 16
    2 3 100
    2 5 15
    5 3 20
    

    Sample Output

    1 3 5 2
    
     Floyd最小环;
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    const int INF = 1e7+5;
    using namespace std;
    int n;
    int dis[105][105];
    int d[105][105];
    int path[105][105];
    int ans[105];
    void init(){
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= n; j++){
                d[i][j] = d[j][i] = dis[i][j] = dis[j][i] = INF;
                path[i][j] = i;
            }
        }
    }
    void floyd(){
        int Min = INF;
        int cnt;
        for(int k = 1; k <= n; k++){
            for(int i = 1; i < k; i++){
                for(int j = i+1; j < k; j++){
                    if(dis[i][j] + d[i][k] + d[k][j] < Min){//若INF = 0x3f3f3f3f,三个数和会超出int范围;
                        Min = dis[i][j] + d[i][k] + d[k][j];
                        cnt = 0;
                        int p = j;
                        while(p != i){
                            ans[cnt++] = p;
                            p = path[i][p];
                        }
                        ans[cnt++] = i;
                        ans[cnt++] = k;
                    }
                }
            }
            for(int i = 1; i <= n; i++){
                for(int j = 1; j <= n; j++){
                    if(dis[i][j] > dis[i][k] + dis[k][j]){
                        dis[i][j] = dis[i][k] + dis[k][j];
                        path[i][j] = path[k][j];
                    }
                }
            }
        }
        if(Min == INF){
            puts("No solution.");
            return;
        }
        for(int i = 0; i < cnt; i++){
            if(i)printf(" ");
            printf("%d",ans[i]);
        }
    }
    int main(){
        int m;
        scanf("%d%d", &n, &m);
        init();
        for(int i = 0; i < m; i++){
            int x, y, w;
            scanf("%d%d%d", &x, &y, &w);
            if(w < d[x][y]){
                d[x][y] = d[y][x] = dis[x][y] = dis[y][x] = w;
            }
        }
        floyd();
        return 0;
    }
  • 相关阅读:
    Android -- DiskLruCache
    Android -- EventBus解析
    Android -- Annotation
    Ubuntu 1604 安装配置 kafka,并配置开机自启(systemctl)
    zookeeper/kafka的部署
    pdf 中内容的坐标系
    C# 获取Windows 设备信息
    C#读取Word指定页的内容
    再看C# ThreadPool与Task的认识总结
    同步IO、异步IO、阻塞IO、非阻塞IO之间的联系与区别
  • 原文地址:https://www.cnblogs.com/ACMessi/p/4883535.html
Copyright © 2011-2022 走看看