zoukankan      html  css  js  c++  java
  • PAT-1120. Friend Numbers (20)

    1120. Friend Numbers (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID's among them. Note: a number is considered a friend of itself.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

    Output Specification:

    For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

    Sample Input:
    8
    123 899 51 998 27 33 36 12
    
    Sample Output:
    4
    3 6 9 26
    

    提交代码

    使用set去重,set是自动排序的,不需要额外排序,并且输出不能使用set[],需要使用iterator。

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int N;
    set<int> numSet;
    
    int sum(int x) {
        int ans = 0;
        while(x != 0) {
            ans += x%10;
            x /= 10;
        }
        return ans;
    }
    
    int main()
    {
        cin>> N;
        int x;
        for(int i = 0; i < N; i++) {
            scanf("%d", &x);
            numSet.insert(sum(x));
        }
        //sort(numSet.begin(), numSet.end());
        set<int>::iterator it;
        int flag = 0;
        cout<< numSet.size()<< endl;
        for (it=numSet.begin(); it!=numSet.end(); ++it) {
            //cout<< flag<< endl;
            if(flag == 1) {
                cout<< " ";
            }
            else {
                flag = 1;
            }
            cout << *it;
        }
        return 0;
    }
  • 相关阅读:
    http
    node 学习 http
    socket.io
    每日日报
    每日日报
    每日日报
    06人件读书笔记之一
    每日日报
    每日日报
    05程序员修炼之道:从小工到专家阅读笔记之三
  • 原文地址:https://www.cnblogs.com/ACMessi/p/8529259.html
Copyright © 2011-2022 走看看