zoukankan      html  css  js  c++  java
  • hdu1065计算几何

    Problem Description

    Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.
    After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)
     
    Input
    The first line of input will be a positive integer indicating how many data sets will be included (N).
    Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.
     
    Output
    For each data set, a single line of output should appear. This line should take the form of:
    “Property N: This property will begin eroding in year Z.”
    Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer.
    After the last data set, this should print out “END OF OUTPUT.”
    Notes:
    1. No property will appear exactly on the semicircle boundary: it will either be inside or outside.
    2. This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.
    3. All locations are given in miles.
     
    Sample Input
    2 1.0 1.0 25.0 0.0
     
    Sample Output
    Property 1: This property will begin eroding in year 1. Property 2: This property will begin eroding in year 20. END OF OUTPUT.
    分析:水题
    题意就是以原点为中心,每年可以侵蚀50平方英里,然后给你一个坐标,问多少年可以侵蚀到那个点
    代码
    #include<iostream>
    using namespace std;
    #define pi 3.1415926
    int main()
    {
     int n,i,k;
     double a,b,c,d;
     cin>>n;
     for(i=1;i<=n;i++){
      cin>>a>>b;
       c=(a*a+b*b);
       d=c*pi/2/50;
        k=(int)d+1;
       cout<<"Property"<<' '<<i<<':'<<' '<<"This property will begin eroding in year"<<' '<<k<<'.'<<endl;
     }
     cout<<"END OF OUTPUT."<<endl;
     return 0;
    }
     
  • 相关阅读:
    Hadoop跳过回收站删除HDFS文件
    hadoop安全模式解除方法和为什么会安全模式
    从业18年,我总结了9个最有价值的经验
    mysql复制整个数据库及数据
    Oozie调度原理(queueName与launcher_queName详解)
    Hive升级参考
    Hive表设计压缩问题
    sql中join的on和where操作引发的谓词下推优化
    将毫秒转换成天小时分钟
    数据库优化之一:通过修改postgresql的Planner Method Configuration更改 查询计划优化慢sql
  • 原文地址:https://www.cnblogs.com/ACWQYYY/p/4487375.html
Copyright © 2011-2022 走看看