zoukankan      html  css  js  c++  java
  • PAT Advanced Level 1053 Path of Equal Weight

    1053 Path of Equal Weight (30)(30 分)

    Given a non-empty tree with root R, and with weight W~i~ assigned to each tree node T~i~. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

    Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

    Figure 1

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 2^30^, the given weight number. The next line contains N positive numbers where W~i~ (&lt1000) corresponds to the tree node T~i~. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

    Output Specification:

    For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

    Note: sequence {A~1~, A~2~, ..., A~n~} is said to be greater than sequence {B~1~, B~2~, ..., B~m~} if there exists 1 <= k < min{n, m} such that A~i~ = B~i~ for i=1, ... k, and A~k+1~ > B~k+1~.

    Sample Input:

    20 9 24
    10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
    00 4 01 02 03 04
    02 1 05
    04 2 06 07
    03 3 11 12 13
    06 1 09
    07 2 08 10
    16 1 15
    13 3 14 16 17
    17 2 18 19

    Sample Output:

    10 5 2 7
    10 4 10
    10 3 3 6 2
    10 3 3 6 2
    /**********************
    author: yomi
    date: 18.8.16
    ps: 本来简单dfs就可以了, 但是要求路径序列要按照非递增顺序输出 这个我想了好一会儿
    甚至想到暂存到string数组里 然后sort 结果这是不现实的 除非再搞个哈希 麻烦
    再看看题 其实就是每次往下搜索时先选权值最大的 所以 我把每一个父结点下的孩子们都按照
    从大到小排了个序。成功解决。
    **********************/
    #include <iostream>
    #include <string>
    #include <vector>
    #include <algorithm>
    using namespace std;
    
    struct Node
    {
        int data;
        int id;
        vector<Node>child;
    }node[150];
    bool vis[150];
    long long int sum = 0, weight;
    vector<int>path;
    int cnt = 0;
    int cmp(Node a, Node b)
    {
        return a.data>b.data;
    }
    void dfs(int index)
    {
        if(node[index].child.size() == 0){
            if(sum == weight){
                for(int i=0; i<path.size()-1; i++){
                    cout << path[i] << ' ';
                }
                cout << path[path.size()-1] << endl;
            }
            return;
        }
        for(int i=0; i<node[index].child.size(); i++){
            int id = node[index].child[i].id;
            if(!vis[id]){
                sum += node[id].data;
                path.push_back(node[id].data);
                dfs(id);
                sum -= node[id].data;
                path.pop_back();
            }
    
        }
    }
    int main()
    {
        int m, n, t, num, d;
        cin >> m >> n >> weight;
        for(int i=0; i<m; i++){
            cin >> node[i].data;
            node[i].id = i;
        }
        for(int i=0; i<n; i++){
            cin >> t >> num;
            for(int j=0; j<num; j++){
                cin >> d;
                node[t].child.push_back(node[d]);
            }
            sort(node[t].child.begin(), node[t].child.end(), cmp);
        }
        sum += node[0].data;
        path.push_back(node[0].data);
        vis[0] = true;
        dfs(0);
    
        return 0;
    }
    /**
    20 9 24
    10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
    00 4 01 02 03 04
    02 1 05
    04 2 06 07
    03 3 11 12 13
    06 1 09
    07 2 08 10
    16 1 15
    13 3 14 16 17
    17 2 18 19
    Sample Output:
    10 5 2 7
    10 4 10
    10 3 3 6 2
    10 3 3 6 2
    **/
  • 相关阅读:
    Java菜鸟之java基础语法,运算符(三)
    Lotus迁移到Exchange 2010 POC 之Domino Server的配置!
    hibernate:对于java.lang.NoSuchMethodError: antlr.collections.AST.getLine()I错误解决办法
    【targeting学习笔记】Display Advertising Targeting
    Domino 迁移到Exchange 之 Domino Admin 安装!
    sqlite3使用详解(Qt版本)
    .net反混淆脱壳工具de4dot的使用
    破解NET的四大神器(转)
    C#让应用程序只运行一个实例的几种方法
    Windows server 2008 R2实现多用户远程连接
  • 原文地址:https://www.cnblogs.com/AbsolutelyPerfect/p/9488757.html
Copyright © 2011-2022 走看看