zoukankan      html  css  js  c++  java
  • F

    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

    InputThe first line contain a integer T , the number of cases. 
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.OutputOne integer per line representing the maximum of the total value (this number will be less than 2 31).Sample Input

    1
    5 10
    1 2 3 4 5
    5 4 3 2 1

    Sample Output

    14
    一个很简单的背包问题,但是用dfs记忆化搜索也可做,并且复杂度相同
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    typedef long long ll;
    const int N=1E3+10;
    int n,m;
    ll v[N];
    ll w[N];
    ll dp[N][N];
    ll dfs(int x,int y){
        ll ans=0; 
        if(x<=0) return 0;
        if(dp[x][y]) return dp[x][y];
        if(w[x]>y) ans=dfs(x+1,y);
        else {
            ans=max(dfs(x+1,y),dfs(x+1,y-w[x])+v[x]);
        }
        return dp[x][y]=ans;
    } 
    int main(){
        int t;
        cin>>t;
        while(t--){
            cin>>n>>m;
            for(int i=1;i<=n;i++){
                cin>>v[i];
            }
            for(int j=1;j<=n;j++)
                cin>>w[j];
            memset(dp,0,sizeof(dp));
            cout<<dfs(1,m)<<endl; 
        }
        
        return 0;
    }

    写dfs的时候一定要清楚它的返回值的意义。

  • 相关阅读:
    一些性能查询的SQL 备忘
    informatica powercenter学习笔记(LookUp 使用)
    BIEE使用技巧
    Linux 系统中用户切换
    手动将自定制的WebPart部署到 SharePoint 2010 中
    C# Process运行cmd命令的异步回显
    Union和Union all的区别
    C#输入输出重定向
    c# 其他技术学习
    Oracle查看所有用户
  • 原文地址:https://www.cnblogs.com/Accepting/p/11290199.html
Copyright © 2011-2022 走看看