zoukankan      html  css  js  c++  java
  • [Usaco2015 Feb]Censoring

    A. Censoring

    题目描述

    Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).
    FJ has taken all of the text from the magazine to create the string S of length at most 10510^5105​​ characters. He has a list of censored words t1t_1t1​​ ... tNt_NtN​​ that he wishes to delete from S. To do so Farmer John finds the earliest occurrence of a censored word in S (having the earliest start index) and removes that instance of the word from S. He then repeats the process again, deleting the earliest occurrence of a censored word from S, repeating until there are no more occurrences of censored words in S. Note that the deletion of one censored word might create a new occurrence of a censored word that didn't exist before.
    Farmer John notes that the censored words have the property that no censored word appears as a substring of another censored word. In particular this means the censored word with earliest index in S is uniquely defined.Please help FJ determine the final contents of S after censoring is complete.
    FJ把杂志上所有的文章摘抄了下来并把它变成了一个长度不超过10510^5105​​的字符串S。他有一个包含n个单词的列表,列表里的n个单词记为t1t_1t1​​...tNt_NtN​​。他希望从S中删除这些单词。
    FJ每次在S中找到最早出现的列表中的单词(最早出现指该单词的开始位置最小),然后从S中删除这个单词。他重复这个操作直到S中没有列表里的单词为止。注意删除一个单词后可能会导致S中出现另一个列表中的单词
    FJ注意到列表中的单词不会出现一个单词是另一个单词子串的情况,这意味着每个列表中的单词在S中出现的开始位置是互不相同的
    请帮助FJ完成这些操作并输出最后的S

    输入格式

    The first line will contain S.
    The second line will contain N, the number of censored words.
    The next N lines contain the strings t1t_1t1​​ ... tNt_NtN​​. Each string will contain lower-case alphabet characters (in the range a..z), and the combined lengths of all these strings will be at most 10510^5105​​.
    第一行包含一个字符串S
    第二行包含一个整数N N<2000 接下来的N行,每行包含一个字符串,第i行的字符串是tit_iti​​

    输出格式

    The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.
    一行,输出操作后的S

    样例

    样例输入

    begintheescapexecutionatthebreakofdawn
    2
    escape
    execution

    样例输出

    beginthatthebreakofdawn

    AC自动机+栈,和之前kmp一样,不过这个是多模式串用到AC自动机。

    trie图中记录单词结尾和单词长度,维护一个栈,依次将字符入栈匹配,若匹配到一个单词的结尾,top-=len单词出栈,用一个数组记录top=i时指针的状态,在弹栈之后将指针恢复即可。

    然而标准的AC自动机会TLE(从此对AC自动机无爱了),所以我又写了一个trie图。

    考试时有人用Hash AC了…(根据第三题的教训),我觉得也应该去学一下……

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<time.h>
    using namespace std;
    struct trie
    {
        int count;
        trie *nxt[26],*fail;
        trie()
        {
            count=0;
            fail=NULL;
            for(int i=0;i<26;i++)nxt[i]=NULL;
        }
    }*q[2000000],*root=new trie();
    int head,tail;
    
    char str[100010];
    char key[100010];
    int n;
    char stack[100010];
    trie *ff[100010];
    int top;
    
    void insert(char s[],trie *root)
    {
        int len=strlen(s);
        trie *p=root;
        int i=0,index;
        while(s[i])
        {
            index=s[i]-'a';
            if(p->nxt[index]==NULL)p->nxt[index]=new trie();
            p=p->nxt[index];
            i++;
        }
        p->count=len;
    }
    void build_ac(trie *root)
    {
        q[++tail]=root;
        while(head!=tail)
        {
            trie *now=q[++head];
            for(int i=0;i<26;++i)
            {
                if(now->nxt[i])
                {
                    if(now==root) now->nxt[i]->fail=now;
                    else now->nxt[i]->fail=now->fail->nxt[i];
                    q[++tail]=now->nxt[i];
                }
                else
                {
                    if(now==root) now->nxt[i]=now;
                    else now->nxt[i]=now->fail->nxt[i]; 
                }
            }
        }
    } 
    inline int read()
    {
        int s=0;char a=getchar();
        while(a<'0'||a>'9')a=getchar();
        while(a>='0'&&a<='9'){s=s*10+a-'0';a=getchar();}
        return s;
    }
    int main()
    {
    //    freopen("in.txt","r",stdin);
    //    freopen("data14.in","r",stdin);
    //    freopen("cen.out","w",stdout);
    
        scanf("%s",str);
        int len=strlen(str);
        n=read();
        for(int i=1;i<=n;i++)
        {
            scanf("%s",key);
            insert(key,root);
        }
        build_ac(root);
        
        int index;
        trie *p=root;
        trie *temp=NULL;
        for(int i=0;i<len;i++)
        {
            stack[++top]=str[i];
            index=str[i]-'a';
            ff[top]=p;
            p=p->nxt[index];
            if(p==NULL)p=root;
            if(p->count)
            {
                top-=p->count;
                p=ff[top+1];
            }
            
        }
        for(int i=1;i<=top;i++)
            putchar(stack[i]);
        return 0;    
    }
    View Code
    波澜前,面不惊。
  • 相关阅读:
    [kafka] 005_kafka_Java_API
    [kafka] 004_kafka_安装运行
    [kafka] 003_kafka_主要配置
    [kafka] 002_kafka_相关术语详细解析
    [kafka] 001_kafka起步
    [随想感悟] 《归去来兮辞·并序》 赏析
    [hadoop] 一些基础概念
    [kylin] 部署kylin服务
    CSAPP 读书笔记
    ubuntu下安装vmTools, 和共享文件
  • 原文地址:https://www.cnblogs.com/Al-Ca/p/11025322.html
Copyright © 2011-2022 走看看