zoukankan      html  css  js  c++  java
  • Poj 2488 A Knight's Journey(搜索)

    Background
    The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
    around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

    Problem
    Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

    poj2488

    Input

    The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
    If no such path exist, you should output impossible on a single line.

    Sample Input

    3
    1 1
    2 3
    4 3

    Sample Output

    Scenario #1:
    A1

    Scenario #2:
    impossible

    Scenario #3:
    A1B3C1A2B4C2A3B1C3A4B2C4


    题意:以国际象棋中的马的行棋规则,不重复遍历一个n*m的棋盘,以输出字典序最小的遍历路径。

    分析:这题首先要清楚国际象棋中的马的行棋规则,每步棋先横走或直走一格,然后再斜走一格,可以越子,也没有“中国象棋”中“蹩马腿”的限制。我就在这里废了不少时间,之前对国际象棋不太了解,虽说题目中有提到,但是那句英语我还是没看懂。回到正题,既然要遍历整个棋盘,那就干脆用回溯法吧。这里要注意的就是那个字典序了,在选择回溯的下一步时要先列后行,这样从A1开始遍历第一次找到的结果就是字典序最小的了。

    import java.util.Scanner;
    
    public class Main {
    
    	static int N, M;
    	static int[][] path;
    	static boolean flag;
    	
    	static boolean isKnightMove(int a, int b, int i, int j) {
    		
    		if (((a - 2 == i || a + 2 == i) && ( b ==j-1 || b==j+1))
    				|| ((b - 2 == j || b + 2 == j)&& (a -1==i||a+1==i))) {
    			return true;
    		}
    		return false;
    	}
    	
    	static void DFS(int n, int nextI, int nextJ, String str) {
    
    		if (n == N * M) {
    			flag=true;
    			System.out.println(str);
    		}
    		
    		if(!flag){
    			//先行后列
    			for (int j = 1; j <= M; j++) {
    				for (int i = 1; i <= N; i++) {
    					if (isKnightMove(nextI, nextJ, i, j) && path[i][j] == 0) {
    						path[i][j] = 1;
    						char c = (char) (j + 64);
    						DFS(n + 1, i, j, str + c + "" + i);
    						path[i][j] = 0;
    					}
    				}
    			}
    		}
    	}
    
    	public static void main(String[] args) {
    		Scanner sc = new Scanner(System.in);
    		int cases=sc.nextInt();
    		for(int i=1;i<= cases;i++){
    			N = sc.nextInt();
    			M = sc.nextInt();
    			flag=false;
    			path = new int[30][30];
    			//从A1开始遍历
    			path[1][1]=1;
    			System.out.println("Scenario #"+i+":");
    			DFS(1, 1,1,"A1");
    			if(!flag){
    				System.out.println("impossible");
    			}
    			System.out.println();
    		}
    		
    	}
    }


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    【转】Uiautomator Api浅析
    【转】UiAutomator简要介绍
    后台自动启动appium
    adb通过wifi连接Android设备
    Python字符串处理和输入输出
    OJ题目输出的生成
    Weka的使用和二次开发(朴素贝叶斯及其属性选择)
    PointNet++论文理解和代码分析
    VGG-16复现
    二维偏序-最长上升子序列的两种求解方式
  • 原文地址:https://www.cnblogs.com/AndyDai/p/4734098.html
Copyright © 2011-2022 走看看