zoukankan      html  css  js  c++  java
  • POJ 2828 Buy Tickets【线段树单点更新+逆序遍历】【经典题】【模板题】

    Buy Tickets
    Time Limit: 4000MS   Memory Limit: 65536K
    Total Submissions: 20782   Accepted: 10237

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

    Source



    题意:有n个人,给出n个人要插入的位置与其价值,输出最后的价值
    思路:由于整个队列是动态不断变化的,所以从最后一个插入的人开始逆推出所有人想要插入的队列并对线段树进行更新即可

    #include<iostream>	
    #include<algorithm>
    #include<cmath>
    #include<cstdio>
    #include<cstdlib>
    #include<queue>
    #include<map>
    #include<set>
    #include<stack>
    #include<bitset>
    #include<numeric>
    #include<vector>
    #include<string>
    #include<iterator>
    #include<cstring>
    #include<functional>
    #define INF 0x3f3f3f3f
    #define ms(a,b) memset(a,b,sizeof(a))
    using namespace std;
    
    const int maxn = 200000 + 10;
    const int mod = 1e9 + 7;
    const double pi = 3.14159265358979;
    
    typedef pair<int, int> P;
    typedef long long ll;
    typedef unsigned long long ull;
    
    int a[maxn << 2], seg[maxn];
    int p[maxn], v[maxn], n;
    
    void pushup(int re)
    {
    	a[re] = a[re << 1] + a[re << 1 | 1];
    }
    
    void build(int l, int r, int rt)
    {
    	if (l == r)
    	{
    		a[rt] = 1;
    		return;
    	}
    	int mid = (l + r) / 2;
    	build(l, mid, rt << 1);
    	build(mid + 1, r, rt << 1 | 1);
    	pushup(rt);
    }
    
    int query(int ll, int rr, int l, int r, int rt)
    {
    	if (ll <= l&&r <= rr) return a[rt];
    	int m = (l + r) >> 1;
    	int ans = 0;
    	if (ll <= m) ans += query(ll, rr, l, m, rt << 1);;
    	if (rr > m) ans += query(ll, rr, m + 1, r, rt << 1 | 1);
    	return ans;
    }
    
    void update(int p, int add, int l, int r, int rt)
    {
    	if (l == r)
    	{
    		a[rt] = 0;
    		seg[l] = add;
    		return;
    	}
    	int m = (l + r) >> 1;
    	if (p <= a[rt<<1]) update(p, add, l, m, rt << 1);
    	else update(p-a[rt<<1], add, m + 1, r, rt << 1 | 1);
    	pushup(rt);
    }
    
    
    int main()
    {
    	while (~scanf("%d", &n))
    	{
    		build(1, n, 1);
    		for (int i = 1; i <= n; i++)
    		{
    			scanf("%d%d", p + i, v + i);
    		}
    		for (int i = n; i > 0; i--)
    		{
    			update(p[i] + 1, v[i], 1, n, 1);
    		}
    		for (int i = 1; i <= n; i++)
    		{
    			printf("%d ", seg[i]);
    		}
    		puts("");
    	}
    	return 0;
    }




    Fighting~
  • 相关阅读:
    Oracle中的函数——Row_Number()
    Oracle中的函数——Concat()
    EM13C添加agent记录两个报错
    优化SQL集一
    只能在工作时间内更新某表
    WARNING OGG-01519
    plsql developer连接oracle 12.2报错 ora-28040 No matching authentication protocol
    Oracle 12.2 报错:ORA-12012: error on auto execute of job "SYS"."ORA$AT_OS_OPT_SY_7458"
    ORA-04021: timeout occurred while waiting to lock object
    记一次 oracle 12.2 RAC : Transaction recovery: lock conflict caught and ignored
  • 原文地址:https://www.cnblogs.com/Archger/p/12774730.html
Copyright © 2011-2022 走看看