zoukankan      html  css  js  c++  java
  • POJ 1159 Palindrome【LCS+滚动数组】【水题】

    Palindrome
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 63833   Accepted: 22254

    Description

    A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

    As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

    Input

    Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

    Output

    Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

    Sample Input

    5
    Ab3bd

    Sample Output

    2

    Source


    给你一个字符串,可在任意位置添加字符,最少再添加几个字符,可以使这个字符串成为回文字符串。
    设原序列S的逆序列为S' ,则最少需要补充的字母数 = 原序列S的长度 —  S和S'的最长公共子序列长度


    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <cmath>
    #include <queue>
    #include <string>
    #include <map>
    #include <cstring>
    #define INF 0x3f3f3f3f
    #define ms(x,y) memset(x,y,sizeof(x))
    using namespace std;
    
    typedef long long ll;
    typedef unsigned long long ull;
    typedef pair<int, int> P;
    
    const int maxn = 5010;
    const int mod = 998244353;
    
    int dp[2][maxn];
    
    int main()
    {
    	string a, b;
    	int n;
    	cin >> n;
    	cin >> a;
    	b = a;
    	reverse(a.begin(), a.end());
    	int ans = -INF;
    	for (int i = 0; i < n; i++)
    	{
    		for (int j = 0; j < n; j++)
    		{
    			if (a[i] == b[j])
    				dp[i % 2][j] = dp[(i + 1) % 2][j - 1] + 1;
    			else
    				dp[i % 2][j] = max(dp[i % 2][j - 1], dp[(i + 1) % 2][j]);
    			ans = max(ans, dp[i % 2][j]);
    		}
    	}
    	cout << n - ans;
    	return 0;
    }




    Fighting~
  • 相关阅读:
    设置光盘为yum源
    oracle11G的安装历程
    数据备份系统治理方案
    设置 MySql 数据同步
    让MySQL与OpenOffice共舞
    My SQL数据库引擎疾速指导1
    MySQL就事器知名网站中的运用量
    MySQL 5.0 新特征教程 存储历程:第三讲
    解决MySQL数据库作古掉以及谢绝任事的办法
    Sun公司将引进新的API对MySQL休止功能调停
  • 原文地址:https://www.cnblogs.com/Archger/p/12774734.html
Copyright © 2011-2022 走看看