zoukankan      html  css  js  c++  java
  • 算法复习——LCA模板(POJ1330)

    题目:

    Description

    A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

     
    In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

    For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

    Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

    Input

    The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

    Output

    Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

    Sample Input

    2
    16
    1 14
    8 5
    10 16
    5 9
    4 6
    8 4
    4 10
    1 13
    6 15
    10 11
    6 7
    10 2
    16 3
    8 1
    16 12
    16 7
    5
    2 3
    3 4
    3 1
    1 5
    3 5
    

    Sample Output

    4
    3
    
    

    Source

    方法:

      LCA模板

    代码:

    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cmath>
    #include<ctime>
    #include<cctype>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<vector>
    using namespace std;
    const int N=30010;
    vector<int>p[N];
    bool visit[N];
    int deep[N],g[N][32];
    int t,a,b,n;
    
    inline void clear()
    {
      memset(g,0,sizeof(g));
      memset(p,0,sizeof(p));
      memset(deep,0,sizeof(deep));
      memset(visit,false,sizeof(visit));
    }
    
    inline void dfs(int u)
    {
      for(int i=0;i<p[u].size();i++)
      {
        int v=p[u][i];
        if(g[u][0]==v)  continue;
        g[v][0]=u;
        deep[v]=deep[u]+1;
        dfs(v);
      }
    }
     
    inline int lca(int a,int b)
    {
      int i;
      if(deep[a]<deep[b])  swap(a,b);
      for(i=0;(1<<i)<=deep[a];i++);
      i--;
      for(int j=i;j>=0;j--)
      {
        if(deep[a]-(1<<j)>=deep[b])
          a=g[a][j];
      }
      if(a==b)  return a;
      for(i=31;i>=0;i--)
      {
        if(g[b][i]!=g[a][i])
        {
          b=g[b][i];
          a=g[a][i];
        }
      }
      return g[a][0];
    }
    
    int main()
    {
      //freopen("a.in","r",stdin);
      //freopen("a.out","w",stdout);
      scanf("%d",&t);
      for(int i=1;i<=t;i++)
      {
        clear();
        int u,v;
        scanf("%d",&n);
        for(int i=1;i<n;i++)
        { 
          scanf("%d%d",&u,&v);
          p[u].push_back(v);
          visit[v]=true;
        }
        for(int i=1;i<=n;i++)
        {
          if(visit[i]==false)
          {  
            dfs(i);
            break;
          }
        }
        for(int i=1;i<32;i++)
          for(int j=1;j<=n;j++)
            g[j][i]=g[g[j][i-1]][i-1];
        scanf("%d%d",&a,&b);  
        cout<<lca(a,b)<<endl;
      }
      return 0;
    }
  • 相关阅读:
    Matlab实现bwlabel函数(区域标记)功能
    Matlab实现medfilt2函数功能
    Matlab实现基于频域对二维信号的低通滤波
    Matlab实现基于频域对一维信号利用傅里叶低通滤波平滑
    Matlab实现直方图规定化
    Matlab实现直方图均衡化
    Matlab实现imresize函数功能
    lc279贪心
    lc347 解法
    numpy中的np.mat(1)
  • 原文地址:https://www.cnblogs.com/AseanA/p/7105428.html
Copyright © 2011-2022 走看看