zoukankan      html  css  js  c++  java
  • 每日一九度之 题目1029:魔咒词典

    时间限制:5 秒

    内存限制:32 兆

    特殊判题:

    提交:5028

    解决:1453

    题目描述:
        哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

        给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
    输入:

        首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

        [魔咒] 对应功能

        其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
        词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

    输出:
        每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
    样例输入:
    [expelliarmus] the disarming charm
    [rictusempra] send a jet of silver light to hit the enemy
    [tarantallegra] control the movement of one's legs
    [serpensortia] shoot a snake out of the end of one's wand
    [lumos] light the wand
    [obliviate] the memory charm
    [expecto patronum] send a Patronus to the dementors
    [accio] the summoning charm
    @END@
    4
    [lumos]
    the summoning charm
    [arha]
    take me to the sky
    样例输出:
    light the wand
    accio
    what?
    what?

    STLmap的入门题。把map弄明白了,就简单了,而且代码也很少。

    不得不说,STL真的很好用啊!

    //Asimple
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <cctype>
    #include <cstdlib>
    #include <stack>
    #include <cmath>
    #include <map>
    #include <string>
    #include <queue>
    #define INF 100000
    using namespace std;
    const int maxn = 105;
    typedef long long ll;
    map<string, string> m;
    string str;
    char s[maxn];
    int n;
    
    int main(){
        while( gets(s) ){
            str = s ;
            if( str == "@END@" ) break;
            string s1, s2;
            int len = str.length();
            int i;
            for(i=0; i<len; i++)
                if( str[i] == ']' )
                    break;
            s1 = str.substr(0,i+1);
            s2 = str.substr(i+2,len);
            //赋值 
            m[s1] = s2 ;
            m[s2] = s1 ;
        }
        scanf("%d
    ",&n);
        while( n -- ){
            gets(s);
            str = s;
            if( m.find(str) == m.end() ){
                cout << "what?" << endl;
            } else {
                str = m[str];
                if( str[0] == '[' ){
                    cout << str.substr(1,str.length()-2) << endl ;
                } else {
                    cout << str << endl ;
                }
            }
        } 
        return 0;
    }
    低调做人,高调做事。
  • 相关阅读:
    大数据学习笔记01
    寻址方式
    指令格式
    虚拟存储器
    高速缓冲存储器Cache
    双端口RAM和多模块存储器
    主存储器与CPU的连接
    半导体存储器
    存储系统——基本概念
    算术逻辑单元
  • 原文地址:https://www.cnblogs.com/Asimple/p/5853179.html
Copyright © 2011-2022 走看看