zoukankan      html  css  js  c++  java
  • 每日一九度之 题目1038:Sum of Factorials

    时间限制:1 秒

    内存限制:32 兆

    特殊判题:

    提交:2109

    解决:901

    题目描述:

        John von Neumann, b. Dec. 28, 1903, d. Feb. 8, 1957, was a Hungarian-American mathematician who made important contributions to the foundations of mathematics, logic, quantum physics, meteorology, science, computers, and game theory. He was noted for a phenomenal memory and the speed with which he absorbed ideas and solved problems. In 1925 he received a B.S. diploma in chemical engineering from Zurich Institute and in 1926 a Ph.D. in mathematics from the University of Budapest, His Ph.D. dissertation on set theory was an important contributions to the subject.
        At the age of 20, von Neumann proposed a new definition of ordinal numbers that was universally adopted. While still in his twenties, he made many contributions in both pure and applied mathematics that established him as a mathematician of unusual depth. His Mathematical Foundation of Quantum Mechanics (1932) built a solid framework for the new scientific discipline.
        During this time he also proved the mini-max theorem of GAME THEORY. He gradually expanded his work in game theory, and with coauthor Oskar Morgenstern he wrote Theory of Games and Economic Behavior (1944).
        There are some numbers which can be expressed by the sum of factorials. For example 9, 9 = 1! + 2! + 3! . Dr. von Neumann was very interested in such numbers. So, he gives you a number n, and wants you to tell whether or not the number can be expressed by the sum of some factorials.
    Well, it is just a piece of case. For a given n, you will check if there are some xi, and let n equal to Σt (上标) i=1(下标) xi! (t≥1, xi≥0, xi = xj <==> i = j)
               t
         即 Σ  xi! (t≥1, xi≥0, xi = xj <==> i = j)
              i=1
        If the answer is yes, say "YES"; otherwise, print out "NO".

    输入:

        You will get a non-negative integer n (n≤1,000,000) from input file.

    输出:

        For the n in the input file, you should print exactly one word ("YES" or "NO") in a single line. No extra spaces are allowed.

    样例输入:
    9
    2
    样例输出:
    YES
    YES

    意思是一个数能不能用一些数的阶乘之和。

    因为规定数在1,000,000之内,所以可以直接枚举。

    //Asimple
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <cctype>
    #include <cstdlib>
    #include <stack>
    #include <cmath>
    #include <map>
    #include <string>
    #include <queue>
    #define INF 100000
    using namespace std;
    const int maxn = 11;
    typedef long long ll;
    int n;
    int a[maxn];
    
    int main(){
        a[0] = 1;
        for(int i=1; i<maxn; i++){
            a[i] = i * a[i-1];
        }
        while( ~scanf("%d",&n) ){
            for(int i=maxn-1; i>=0; i--){
                if( n >= a[i] ){
                    n -= a[i];
                }
            }
            printf(n==0?"YES
    ":"NO
    ");
        }
        return 0;
    }
    低调做人,高调做事。
  • 相关阅读:
    10 Unit Testing and Automation Tools and Libraries Java Programmers Should Learn
    nginx unit java 试用
    Oracle Trace文件生成及查看
    记录数过亿条的表数据维护-数据删除
    对于上千万甚至上亿的数据,如何正确的删除?
    怎么快速删除大数据量表
    如何启动或关闭oracle的归档(ARCHIVELOG)模式
    oracle清理归档日志(缓存)
    HTTP和HTTPS协议,看一篇就够了
    HTTP与HTTPS对访问速度(性能)的影响
  • 原文地址:https://www.cnblogs.com/Asimple/p/5886803.html
Copyright © 2011-2022 走看看