zoukankan      html  css  js  c++  java
  • 算法竞赛入门经典训练指南——UVA 11300 preading the Wealth

    A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

    Input

    There is a number of inputs. Each input begins with n (n < 1000001), the number of people in the village. n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

    Output

    For each input, output the minimum number of coins that must be transferred on a single line.

    Sample Input

    3

    100

    100

    100

    4

    1

    2

    5

    4

    Sample Output

    0

    4

    算法竞赛入门经典训练指南上有题意与分析,不懂的可以去翻阅。

     //Asimple
    #include <bits/stdc++.h>
    #define INF (1<<20)
    #define mod 10007
    #define swap(a,b,t) t = a, a = b, b = t
    #define CLS(a, v) memset(a, v, sizeof(a))
    #define debug(a)  cout << #a << " = "  << a <<endl
    using namespace std;
    typedef long long ll;
    const int maxn = 1000001;
    ll n, m, res, ans, len, T, k, num, sum;
    ll x, y;
    ll a[maxn], c[maxn];
    
    /*
    假设 An表示n个人原有的金币数
    xn表示第n个人给n-1个人xn枚金币(x1表示1给n)
    M表示最终每个人拥有的金币数 
    则可推出通式: xn = x1-Cn 其中 Cn = A1+A2+...+An-n*M
    由于要求是最小的金币数,所以x1应当取C数组的中位数 
    */
    
    void input() {
        ios_base::sync_with_stdio(false);
        while( cin >> n ) {
            sum = 0;
            for(int i=1; i<=n; i++) {
                cin >> a[i];
                sum += a[i];
            }
            ll M = sum / n;
            c[0] = 0;
            for(int i=1; i<n; i++)
                c[i] = c[i-1]+a[i]-M;
            sort(c, c+n);
            ll x1 = c[n/2];
            ans = 0;
            for(int i=0; i<n; i++)
                ans += abs(x1-c[i]);
            cout << ans << endl;
        }
    }
    
    int main(){
        input();
        return 0;
    }
  • 相关阅读:
    [置顶] 2013年工作中遇到的20个问题(Bug):161-180
    Spring 3.1.1使用Mvc配置全局日期转换器,处理日期转换异常
    Java中ThreadLocal模拟和解释
    平衡
    一步一步学数据结构之1--n(二叉树遍历--非递归实现)
    RobotFramework+Selenium2环境搭建与入门实例
    UVA10168
    ubantu系统Django安装教程
    The connection to adb is down, and a severe error has occured完整解决办法
    服务端分页
  • 原文地址:https://www.cnblogs.com/Asimple/p/6837720.html
Copyright © 2011-2022 走看看