zoukankan      html  css  js  c++  java
  • UVA

    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

    This problem requires that you write a program to compute the exact value of Rn where R is a real number (0.0 < R < 99.999) and n is an integer such that 0 < n ≤ 25.

    Input 

    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

    Output 

    The output will consist of one line for each line of input giving the exact value of Rn. Leading zeros and insignificant trailing zeros should be suppressed in the output.

    Sample Input 

    95.123 12
    0.4321 20
    5.1234 15
    6.7592  9
    98.999 10
    1.0100 12
    

    Sample Output 

    548815620517731830194541.899025343415715973535967221869852721
    .00000005148554641076956121994511276767154838481760200726351203835429763013462401
    43992025569.928573701266488041146654993318703707511666295476720493953024
    29448126.764121021618164430206909037173276672
    90429072743629540498.107596019456651774561044010001
    1.126825030131969720661201

    有趣的大数幂运算,如果直接用BigDecimal的话会错误,需要进行一点小小的处理。

    import java.math.BigDecimal;
    import java.util.Scanner;
    
    /**
     * 
     * @author Asimple
     * @date ${date}
     * 
     */
    
    public class Main{
        
        public static BigDecimal fun(BigDecimal num, int n) {
            if( n==1 ) return num;
            if( n%2==0 ) return fun(num,n/2).multiply(fun(num,n/2));
            else return fun(num,n/2).multiply(fun(num,n/2)).multiply(num);
        }
        
        static Scanner sc = new Scanner(System.in);
        public static void main(String[] args) {
            BigDecimal a;
            int n;
            while( sc.hasNext() ) {
                a = sc.nextBigDecimal();
                n = sc.nextInt();
                String ans = "";
                ans = fun(a,n).stripTrailingZeros().toPlainString();  
                if(ans.charAt(0) == '0') {  
                    int i;  
                    for(i=0; i<ans.length(); i++) 
                        if(ans.charAt(i) != '0')
                            break;  
                    System.out.println(ans.substring(i));  
                }
                else  System.out.println(ans);  
            }
        }
    }
  • 相关阅读:
    NET下RabbitMQ实践[WCF发布篇]
    基于Mongodb分布式存储物理文件
    NET下RabbitMQ实践[实战篇]
    关于Memcache mutex设计模式的.net实现
    使用ServiceStackRedis链接Redis简介
    NET下RabbitMQ实践[示例篇]
    基于MongoDB分布式存储进行MapReduce并行查询
    Asp.Net开发小技巧汇总
    愈敏洪讲座
    图标下载利器
  • 原文地址:https://www.cnblogs.com/Asimple/p/6899558.html
Copyright © 2011-2022 走看看