zoukankan      html  css  js  c++  java
  • Let's Chat ZOJ

    ACM (ACMers' Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:

    If two users, A and B, have been sending messages to each other on the last mconsecutive days, the "friendship point" between them will be increased by 1 point.

    More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m + 1)-th day and the i-th day (also both inclusive), the "friendship point" between A and B will be increased by 1 at the end of the i-th day.

    Given the chatting logs of two users A and B during n consecutive days, what's the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?

    Input

    There are multiple test cases. The first line of input contains an integer T (1 ≤ T≤ 10), indicating the number of test cases. For each test case:

    The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ m ≤ n), x and y (1 ≤ xy ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.

    For the following x lines, the i-th line contains 2 integers lai and rai (1 ≤ la,i ≤ rai ≤ n), indicating that A sent messages to B on each day between the lai-th day and the rai-th day (both inclusive).

    For the following y lines, the i-th line contains 2 integers lbi and rbi (1 ≤ lb,i ≤ rbi ≤ n), indicating that B sent messages to A on each day between the lbi-th day and the rbi-th day (both inclusive).

    It is guaranteed that for all 1 ≤ i < xrai + 1 < lai + 1 and for all 1 ≤ i < yrbi + 1 < lbi + 1.

    Output

    For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.

    Sample Input

    2
    10 3 3 2
    1 3
    5 8
    10 10
    1 8
    10 10
    5 3 1 1
    1 2
    4 5
    

    Sample Output

    3
    0
    

    Hint

    For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. As m = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer is 3.

    题意:

    给出x(1<=x<=100)个区间和y(1<=y<=100)个区间,求出存在几个长度为m(1<=m<=n)公共子区间。

    把题目样例看懂了,基本上题目就会做了。

    // Asimple
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstdlib>
    #include <queue>
    #include <vector>
    #include <string>
    #include <cstring>
    #include <stack>
    #define INF 0x3f3f3f3f
    #define mod 2016
    using namespace std;
    typedef long long ll;
    typedef unsigned long long ull;
    const int maxn = 105;
    int n, m, T, len, cnt, num, Max;
    int x, y;
    
    struct node{
        int l;
        int r;
    };
    node a[maxn], b[maxn];
    
    void input() {
        scanf("%d", &T);
        while( T -- ) {
            cin >> n >> m >> x >> y;
            memset(a, 0, sizeof(a));
            memset(b, 0, sizeof(b));
            for(int i=0; i<x; i++) {
                cin >> a[i].l >> a[i].r;
            }
            for(int i=0; i<y; i++) {
                cin >> b[i].l >> b[i].r;
            }
            int cnt = 0;
            for(int i=0; i<x; i++) {
                if( a[i].r-a[i].l+1 < m ) continue; 
                for(int j=0; j<y; j++) {
                    if( b[j].r-b[j].l+1 < m ) continue;
                    int l = max(a[i].l, b[j].l);
                    int r = min(a[i].r, b[j].r);
                    if( r - l + 1 >= m ) {
                        cnt += r-l+1 -m+1;
                    }
                }
            }
            cout << cnt << endl;
        } 
    }
    
    int main() {
        input();
        return 0;
    } 
  • 相关阅读:
    北京Uber优步司机奖励政策(3月3日)
    ubuntu安装phpstorm
    ubuntu安装typora
    PHP定时任务Crontab结合CLI模式详解
    mysql创建用户,并授予权限
    ubuntu下使用crontab定时器
    Ubuntu 查看当前目录使用的总空间大小
    ubuntu安装ruby,安装sass,安装compass
    open_basedir restriction in effect,解决php引入文件权限问题 lnmp
    canvas 画线
  • 原文地址:https://www.cnblogs.com/Asimple/p/7384328.html
Copyright © 2011-2022 走看看