zoukankan      html  css  js  c++  java
  • UVa——400Unix ls(字典序文本处理输出iomanip)

    Unix ls

    Time Limit:                                                        3000MS                           Memory Limit: Unknown   64bit IO Format:                            %lld & %llu                        

                                            Status                             

    Description

    Download as PDF
     

    The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for thels function.

    Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right.

    Input

    The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (tex2html_wrap_inline41 ). There will then beN lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a toz, A to Z, and 0 to 9) and from the following set{ ._- } (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

    Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.

    Output

    For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 toR will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.

    Sample Input

    10
    tiny
    2short4me
    very_long_file_name
    shorter
    size-1
    size2
    size3
    much_longer_name
    12345678.123
    mid_size_name
    12
    Weaser
    Alfalfa
    Stimey
    Buckwheat
    Porky
    Joe
    Darla
    Cotton
    Butch
    Froggy
    Mrs_Crabapple
    P.D.
    19
    Mr._French
    Jody
    Buffy
    Sissy
    Keith
    Danny
    Lori
    Chris
    Shirley
    Marsha
    Jan
    Cindy
    Carol
    Mike
    Greg
    Peter
    Bobby
    Alice
    Ruben

    Sample Output

    ------------------------------------------------------------
    12345678.123         size-1               
    2short4me            size2                
    mid_size_name        size3                
    much_longer_name     tiny                 
    shorter              very_long_file_name  
    ------------------------------------------------------------
    Alfalfa        Cotton         Joe            Porky          
    Buckwheat      Darla          Mrs_Crabapple  Stimey         
    Butch          Froggy         P.D.           Weaser         
    ------------------------------------------------------------
    Alice       Chris       Jan         Marsha      Ruben       
    Bobby       Cindy       Jody        Mike        Shirley     
    Buffy       Danny       Keith       Mr._French  Sissy       
    Carol       Greg        Lori        Peter

    题意:输入N后有N段字符串,读入进行按字典序排序,然后按尽量少行数输出,每行最多60个字符,因此最大列数colum=(60-maxlen)/(maxlen+2)+1;当然maxlen最长字符串的长度,行数row=(int)(ceil( (double)t/colum) )。然后最后一列的每个字符串输出占位数为maxlen,其他为maxlen+2。题意刚开始看不懂,直接百度了。

    代码:

    #include<iostream>
    #include<algorithm>
    #include<string>
    #include<cmath>
    #include<cstdio>
    #include<set>
    #include<sstream>
    #include<map>
    #include<vector>
    #include<iomanip>
    using namespace std;
    bool cmp(const string &a,const string &b)
    {
    	return a<b;
    }
    int main(void)
    {
    	int t,maxlen,colum,row;
    	while (cin>>t)
    	{
    		string list[1000];
    		maxlen=0;
    		for (int q=0; q<t; q++)
    		{
    			cin>>list[q];
    			maxlen=max(maxlen,(int)list[q].size());//计算字符串最大长度
    		}
    		sort(list,list+t,cmp);//字典序排序
    		colum=(60-maxlen)/(maxlen+2)+1;//计算列数
    		row=(int)(ceil((double)t/colum));//计算行数
    		cout<<"------------------------------------------------------------"<<endl;
    		for (int i=0; i<row; i++)//行外循环
    		{
    			for (int j=0; j<colum; j++)//列内循环
    			{
    				if(j<colum-1)
    					cout<<left<<setw(maxlen)<<list[j*row+i]<<"  ";//不是最后一列,maxlen再多输俩空格
    				else
    					cout<<left<<setw(maxlen)<<list[j*row+i];//按maxlen输出
    			}
    			cout<<endl;
    		}
    	}
    	return 0;
    }
  • 相关阅读:
    jQueryUI的widget的Hello World
    jquery.fileupload源码解读笔记
    起始路由改成分区(Areas)的RouteConfig.cs配置方法
    C++/CLI
    WM_COPYDATA 进程间通信
    C# 托管内存与非托管内存之间的转换
    迟延(Lazy)加载导出部件(Export Part)与元数据(Metadata)
    Bitmap(Type, String) 图片路径
    C# GetManifestResourceStream获取资源为null
    C#可扩展编程之MEF学习笔记(二):MEF的导出(Export)和导入(Import)
  • 原文地址:https://www.cnblogs.com/Blackops/p/5356417.html
Copyright © 2011-2022 走看看