zoukankan      html  css  js  c++  java
  • HDU1213How Many Tables(基础并查集)

    HDU1213How Many Tables

    Problem Description

    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

    Input

    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

    Output

    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

    Sample Input

    2
    5 3
    1 2
    2 3
    4 5

    5 1
    2 5

    Sample Output

    2
    4
     
    题意:
      给定T组数据,每组数据给定一个伙伴关系,若A与B是朋友,B与C是朋友,那么A和C也是朋友,具有朋友关系的可以坐在同一张桌子上,假设桌子足够大,问需要多少个桌子。
    解题方法:
      这里我们使用并查集来判断各个人是否具有伙伴关系,若有归于同一类,最后统计有多少类即为多少张桌子。
     
    代码:
    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int maxn=20000;
    int pre[maxn],height[maxn];
    void init_set(int n){
        for (int i = 1; i <= n; i++){
            pre[i]=i;    
        }
        memset(height,0,sizeof(height));
    }
    
    int find_set(int x){
        return x==pre[x]?x:pre[x]=find_set(pre[x]);
    }
    void union_set(int x,int y){
        x= find_set(x);
        y= find_set(y);
        if(x==y)return;
        if(height[x]==height[y]){
            height[x]=height[x]+1;
            pre[y]=x;
        }else{
            if(height[x]<height[y]) pre[x]=y;
            else{
                pre[y]=x;
            }
        }
    }
    
    int main(){
        int T;
        cin>>T;
        int n,m,a,b;
        while (T--){
            cin>>n>>m;
            init_set(n);
            int sum=0;
            while (m--){
                cin>>a>>b;
                union_set(a,b);
            }
            for (int i = 1; i <=n; i++)
            {
                if(i==pre[i])sum++;
            }
            cout<<sum<<endl;
        }
    }
    View Code

     

     
     
     

    因上求缘,果上努力~~~~ 作者:每天卷学习,转载请注明原文链接:https://www.cnblogs.com/BlairGrowing/p/14290665.html

  • 相关阅读:
    程序向informix数据库插入text类型的中文乱码问题
    深入理解Java:注解(Annotation)基本概念
    ssm架构的理解
    队列的java实现
    栈的java实现
    LinkedList的实现原理
    ArrayList的实现
    快速排序
    数据结构之桶排序
    leetcode
  • 原文地址:https://www.cnblogs.com/BlairGrowing/p/14290665.html
Copyright © 2011-2022 走看看