zoukankan      html  css  js  c++  java
  • PAT World Cup Betting[非常简单]

    1011 World Cup Betting (20)(20 分)

    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.0  1.6
    4.1  1.2  1.1
    

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

    Input

    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

    Output

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

    Sample Input

    1.1 2.5 1.7
    1.2 3.0 1.6
    4.1 1.2 1.1
    

    Sample Output

    T T W 37.98

    //题目大意就是给出3*3矩阵,每一行表示一次比赛的结果,W是赢了,T是平局,L是输了,就找出每局的最大值做一个运算即可。

    //这道题真的很简单。。

    一次就AC。。

    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include<map>
    #include<stack>
    #include<math.h>
    using namespace std;
    
    int main()
    {
        int maxs[3];//记录每一行是第几个数最大。
        fill(maxs,maxs+3,0);
        double a[3][3];
        map<int,char> mp;
        mp.insert(make_pair(0,'W'));
        mp.insert(make_pair(1,'T'));
        mp.insert(make_pair(2,'L'));
        //freopen("1.txt","r",stdin);
        for(int i=0;i<3;i++){
            int ma=0;
            for(int j=0;j<3;j++){
                scanf("%lf",&a[i][j]);
                if(a[i][j]>ma){
                    maxs[i]=j;
                    ma=a[i][j];
                }
            }
        }
        double x=1.0;
        for(int i=0;i<3;i++)
            x*=a[i][maxs[i]];
        x=(x*0.65-1)*2;
        printf("%c %c %c %.2f",mp[maxs[0]],mp[maxs[1]],mp[maxs[2]],x);
        return 0;
    }//出现了一个问题,样例中答案是37.98,但是我算出来的结果是37.97,这个结果难以接受。。
    //妈耶,但是提交了之后通过了,20分。。

    //没什么好说的了。就是在map插入的时候要用make_pair,不能直接插入。

  • 相关阅读:
    人这一辈子
    理性不是逆来顺受
    旧瓶新酒:江城子
    HVAC专业相关网站
    韩寒:主子,奴才和狗
    百无一用是书生
    inove主题文章字体修改
    这个世界清净了:再见人人
    ActiveX控件开发(转)
    GIS大讲堂内所有讲座的索引(更新至2008年6月26日)(转)
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9340710.html
Copyright © 2011-2022 走看看