zoukankan      html  css  js  c++  java
  • PAT 1076 Forwards on Weibo[BFS][一般]

    1076 Forwards on Weibo (30)(30 分)

    Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

    M[i] user_list[i]

    where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

    Then finally a positive K is given, followed by K UserID's for query.

    Output Specification:

    For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

    Sample Input:

    7 3
    3 2 3 4
    0
    2 5 6
    2 3 1
    2 3 4
    1 4
    1 5
    2 2 6

    Sample Output:

    4
    5

     题目大意:给出一个关注网络,检测在L内,一个用户发帖,最多有多少个转发量,像是宽度优先遍历,是有向图。

    #include <iostream>
    #include <algorithm>
    #include <vector>
    #include<queue>
    using namespace std;
    vector<int> user[1010];
    int vis[1010];
    int main() {
        int n,L;
        queue<int> qu;
        cin>>n>>L;
        int k,temp;
        for(int i=1;i<=n;i++){
            cin>>k;
            for(int j=0;j<k;j++){
                cin>>temp;
                user[temp].push_back(i);
            }
        }
        cin>>k;
        int ct=0,level=0,num;
        for(int i=0;i<k;i++){
            fill(vis,vis+n+1,0);//开心到哭泣,这里错了,导致过不去,因为编号是从1-n,所以就导致了最后一个点被赋值为1之后,一直为1.
            cin>>temp;
            ct=0,level=0;
            while(!qu.empty())qu.pop();
            qu.push(temp);
            vis[temp]=1;
            qu.push(-1);
            while(level!=L){
                while(!qu.empty()){
                    num=qu.front();
                    qu.pop();
                    if(num==-1){
                        qu.push(-1);
                        break;
                    }
                    for(int j=0;j<user[num].size();j++){
                        if(!vis[user[num][j]]){
                            qu.push(user[num][j]);//将其放入
                            vis[user[num][j]]=1;
                            ct++;
                        }
                    }
                }
                level++;
            }
            cout<<ct;
            if(i!=k-1)cout<<'\n';
        }
        return 0;
    }

    我的AC代码,一般出现段错误就是数组长度设置的太小了,反正这次是这样。

    1.还有一个困扰我的地方,“and that only L levels of indirect followers are counted.”,这里其实是很简单,并不是第一层的不算,所有的能转发的人都算在内。 

  • 相关阅读:
    关于TileBrush中Viewbox,Viewport以及Stretch,AlignmentX/Y的详细研究
    ListBox数据绑定无效
    WPF---Effect效果
    wpf 画刷的分类
    LinearGradientBrush,RadialGradientBrush的样式说明
    改变ListBoxItem选中的颜色
    自定义的 ListBoxItem 自适应ListBox的宽度
    WPF ListBox数据绑定
    ItemsPanelTemplate的用法
    svn报错Item is not readable svn解决方案
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9456610.html
Copyright © 2011-2022 走看看