zoukankan      html  css  js  c++  java
  • PAT 1072 Gas Station[图论][难]

    1072 Gas Station (30)(30 分)

    A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

    Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 10^3^), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 10^4^), the number of roads connecting the houses and the gas stations; and D~S~, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

    Then K lines follow, each describes a road in the format\ P1 P2 Dist\ where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

    Output Specification:

    For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

    Sample Input 1:

    4 3 11 5
    1 2 2
    1 4 2
    1 G1 4
    1 G2 3
    2 3 2
    2 G2 1
    3 4 2
    3 G3 2
    4 G1 3
    G2 G1 1
    G3 G2 2

    Sample Output 1:

    G1
    2.0 3.3

    Sample Input 2:

    2 1 2 10
    1 G1 9
    2 G1 20

    Sample Output 2:

    No Solution

     //看了好几遍,终于理解了题目的意思。并且搜索别的题解。

     1.修建加油站,要求加油站能够服务所有的居民屋子,是有距离限制的。

    2.要求距离加油站最近的屋子最远,出于安全的考虑。

    3.如果这些要求满足,那么输出到所有居民屋子平均距离最短的。

    4.同等条件下,输出编号最小的。

    代码来自:https://www.liuchuo.net/archives/2376

    #include <iostream>
    #include <algorithm>
    #include <string>
    using namespace std;
    const int inf = 999999999;
    int n, m, k, ds, station;
    int e[1020][1020], dis[1020];
    
    bool visit[1020];
    int main() {
        fill(e[0], e[0] + 1020 * 1020, inf);
        fill(dis, dis + 1020, inf);
        scanf("%d%d%d%d", &n, &m, &k, &ds);
        for(int i = 0; i < k; i++) {
            int tempdis;
            string s, t;
            cin >> s >> t >> tempdis;
            int a, b;
            if(s[0] == 'G') {
                s = s.substr(1);
                a = n + stoi(s);
            } else {
                a = stoi(s);
            }
            if(t[0] == 'G') {
                t = t.substr(1);
                b = n + stoi(t);
            } else {
                b = stoi(t);
            }
            e[a][b] = e[b][a] = tempdis;
        }
        int ansid = -1;
        double ansdis = -1, ansaver = inf;
        for(int index = n + 1; index <= n + m; index++) {
            double mindis = inf, aver = 0;
            fill(dis, dis + 1020, inf);
            fill(visit, visit + 1020, false);
            dis[index] = 0;
            for(int i = 0; i < n + m; i++) {
                int u = -1, minn = inf;
                for(int j = 1; j <= n + m; j++) {
                    if(visit[j] == false && dis[j] < minn) {
                        u = j;
                        minn = dis[j];
                    }
                }
                if(u == -1) break;
                visit[u] = true;
                for(int v = 1; v <= n + m; v++) {
                    if(visit[v] == false && dis[v] > dis[u] + e[u][v])
                        dis[v] = dis[u] + e[u][v];
                }
            }
            for(int i = 1; i <= n; i++) {
                if(dis[i] > ds) {
                    mindis = -1;
                    break;
                }
                if(dis[i] < mindis) mindis = dis[i];
                //mindis是加油站到某个居民屋子的最短距离。
                aver += 1.0 * dis[i];
            }
            if(mindis == -1) continue;
            aver = aver / n;
            if(mindis > ansdis) {
                ansid = index;
                ansdis = mindis;
                ansaver = aver;
            } else if(mindis == ansdis && aver < ansaver) {
                ansid = index;
                ansaver = aver;
            }
        }
        if(ansid == -1)
            printf("No Solution");
        else
            printf("G%d\n%.1f %.1f", ansid - n, ansdis, ansaver);
        return 0;
    }

    //大佬写的可真好,思路清晰,代码简洁!关键是将加油站接着存在了居民屋后面,省空间,而且好遍历,这个我肯定想不到。厉害。

  • 相关阅读:
    golang类型判断
    golang文件相对路径问题
    golang中数组与切片的区别
    golang的一些基础数据类型转换
    golang变量的注意
    Oracle数据库导入导出总结(dmp文件)
    Ajax,谷歌提示AutoCompleteExtender控件
    验证控件插图扩展控件ValidatorCalloutExtender(用于扩展验证控件)和TextBoxWatermarkExtender
    当使用母版页时JavaScript客户端获取服务器控件的Id
    实现GridView翻页并且实现CheckBox选中功能的保持
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9462606.html
Copyright © 2011-2022 走看看