zoukankan      html  css  js  c++  java
  • PAT 1079 Total Sales of Supply Chain[比较]

    1079 Total Sales of Supply Chain(25 分)

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (105​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki​​ ID[1] ID[2] ... ID[Ki​​]

    where in the i-th line, Ki​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj​​. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010​​.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3
    

    Sample Output:

    42.4

    题目大意:给出树结构,找出零售商的总和。给出了供应商的原价,每经过一个经销商或者零售商价格上涨r%.求最终利润。

    //我对题目的理解不好,这个r是个百分数,所以要/100,才可以的,并且当k=0时,后边存储的数是每个零售商的销量。 

    #include <iostream>
    #include <vector>
    #include <map>
    #include<stdio.h>
    #include<cmath>
    using namespace std;
    vector<int> vt[100000];
    map<int,int> mp;
    double sum=0;
    double p,r;
    void dfs(int nd,int level){
        if(vt[nd].size()==0){
            double temp=0;
            temp=pow(1+r,level)*mp[nd];
            sum+=temp;
            return ;
        }
        for(int i=0;i<vt[nd].size();i++){
            dfs(vt[nd][i],level+1);
        }
    }
    
    int main() {
        int n;
        scanf("%d %lf %lf",&n,&p,&r);
        r=r/100;
        int tempk,temp;
        for(int i=0;i<n;i++){
            scanf("%d",&tempk);
            for(int j=0;j<tempk;j++){
                scanf("%d",&temp);
                vt[i].push_back(temp);
            }
            if(tempk==0){
                scanf("%d",&temp);
                mp[i]=temp;
            }
        }
        dfs(0,0);
        printf("%.1f",sum*p);
        return 0;
    }

    //第一次提交发生了段错误,检查发现是数据设置的太小了,应该是10^5才行,

    1.使用邻接表来存储树,使用dfs进行遍历;

    2.需要记住dfs的代码结构,首先是递归出口,出口处需要进行相应的计算;再是进行循环递归。

  • 相关阅读:
    OP_REQUIRES failed at conv_ops.cc:386 : Resource exhausted: OOM when allocating tensor with shape..
    Python中*args和**kwargs的区别
    命令行运行Python脚本时传入参数的三种方式
    关于 initWithNibName 和 loadNibNamed 的区别和联系-iPhone成长之路
    NSBundle介绍
    UIView总结
    iPhone How-to:如何调整UIView的Z-Order
    有关View的几个基础知识点-IOS开发
    NSNumber与NSInteger的区别
    iOS第三方开源库的吐槽和备忘
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9515066.html
Copyright © 2011-2022 走看看