zoukankan      html  css  js  c++  java
  • PAT 1090 Highest Price in Supply Chain[较简单]

    1090 Highest Price in Supply Chain(25 分)

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

    Input Specification:

    Each input file contains one test case. For each case, The first line contains three positive numbers: N (105​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si​​ is the index of the supplier for the i-th member. Sroot​​for the root supplier is defined to be 1. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010​​.

    Sample Input:

    9 1.80 1.00
    1 5 4 4 -1 4 5 3 6
    

    Sample Output:

    1.85 2

     题目大意:也是一个销售链,给出一个树结构,求数的高度,并且在最高的叶节点有几个。

    //这个和1079是类似的,都是使用dfs吧!传参进去一定要有level咯,记住maxLevel和每个叶节点的层数即可。

    #include <iostream>
    #include<stdio.h>
    #include<cmath>
    #include<vector>
    using namespace std;
    double p,r;
    vector<int> tree[100001];
    int book[100001];
    int maxL=0;
    void dfs(int index,int level){
        if(tree[index].size()==0){
            book[index]=level;
            if(level>maxL)
                maxL=level;
            return ;
        }
        for(int i=0;i<tree[index].size();i++)
            dfs(tree[index][i],level+1);
    }
    
    int main() {
        int n;
        scanf("%d %lf %lf",&n,&p,&r);
        int temp,root=-1;
        for(int i=0;i<n;i++){
            scanf("%d",&temp);
            if(temp!=-1){
                tree[temp].push_back(i);
            }
            else root=i;
        }
        dfs(root,0);
        int ct=0;
        for(int i=0;i<n;i++){
            if(book[i]==maxL)
                ct++;
        }
        printf("%.2f %d",p*pow(1+r/100,maxL),ct);
        return 0;
    }

    //一次通过,简直非常开心了!我应该把关于树的深度遍历,高度,这些东西都掌握了。非常开心。

    1.树的dfs都是有结构的,非常简单。

    2.需要记录叶节点的高度。

  • 相关阅读:
    【NX二次开发】修改dlx对话框标题的方法
    【NX二次开发】导入x_t,UF_PS_import_data
    设置NX欢迎界面
    [转]10个顶级的CSS UI开源框架
    [转] 多线程 《深入浅出 Java Concurrency》目录
    [转] JAVA多线程和并发基础面试问答
    [转]StuQ 技能图谱(全套13张)
    [转] MongoDB shell 操作 (查询)
    搜集好的java技术帖子,持续更新,java程序员的要求
    [转]JAVA程序员一定知道的优秀第三方库(2016版)
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9522846.html
Copyright © 2011-2022 走看看